cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

HTTP GET - Flow returns 301 error - Same attempt via Postman returns 200-OK?

Hi,

 

I am building a flow to automate responses to alerts from Microsoft Cloud App Security. As part of the flow I need to perform a HTTP GET request for an alert. This then generates a response in JSON I can then parse to retrieve the information I require.

 

I have crafted the flow but am receiving an error when using the HTTP GET module in flow.

 

The request essentially sends a HTTP GET request to a dynamic URI and sends a header value that contains the relevant API token.

 

 

Capture.PNG

 

I have performed the operation in postman with a header key of "Authorization" and value of "token <token value>" and this works

 

I have configured the same in the HTTP module in flow which fails every test - if I review the results of the failure I can see the URI is correct (as if I cut and paste the URI used into postman and use it, it works). I cant see the token being sent as the result is sanitised in the flow output, however the header value in the HTTP module is identical (and also works if cut and pasted into postman).

 

Is there any further debugging I can do to get to the bottom of this?

 

3 REPLIES 3
Highlighted
Solution Sage
Solution Sage

Hi @cdf_pjr ,

 

Authorization token should be in format : Bearer {0} . have you tried doing that ?

 

Thanks

Highlighted

If I use a bearer token in Postman it fails?

 

I have seen token used exactly as I am attempting in this video https://youtu.be/-vZucJr6Vck?t=2498 which is what I am trying to replicate.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (14,268)