cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Diguardi
Frequent Visitor

Help using teams option from extracted excel

Error details: The request failed. Error code: 'MissingOrInvalidBotMessageWithOptionsRequest'. Error Message: 'The specified Teams flowbot message with options request is missing or invalid.'.

The full flow is from a forms updating a table in excel. And then I want to use the new row with a formula to ask in teams which option of the 5 they have available they will use. Then input the data from that message into the excel and send a message to the person who filled out the form what they will be getting.

I have a flow going from an excel workbook where I have to ask a teams member to answer an options question before proceeding. If you can see I have a delay from the time I enter the data from the Form into the excel sheet. This is to provide enough time for the formulas in the other cells to copy and update. Once they are updated I have tried "get row" which works but the sending a teams with options of what should be used is not working. I have no idea if the rest of the flow after works because it stops there.

 

 

Capture3.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Diguardi
Frequent Visitor

BadRequest. The request failed. Error code: 'MissingOrInvalidBotMessageWithOptionsRequest'. Error Message: 'The specified Teams flowbot message with options request is missing or invalid.'.

I ended up resolving the error by inserting a get from excel. I also found that the options I had in there from the Dynamic Content was under the 'add a row' in excel section instead of the 'get a row' section.

Once the options were under the 'get a row' it worked perfectly.

Thank you for all your help!

View solution in original post

2 REPLIES 2
joe_hannes_col
Continued Contributor
Continued Contributor

Hello @Diguardi,

 

Could you please post the full error message? There should be some technical details after the part you posted. This error usually occurs when the message you are trying to send through the bot is not formatted correctly.

Diguardi
Frequent Visitor

BadRequest. The request failed. Error code: 'MissingOrInvalidBotMessageWithOptionsRequest'. Error Message: 'The specified Teams flowbot message with options request is missing or invalid.'.

I ended up resolving the error by inserting a get from excel. I also found that the options I had in there from the Dynamic Content was under the 'add a row' in excel section instead of the 'get a row' section.

Once the options were under the 'get a row' it worked perfectly.

Thank you for all your help!

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Users online (1,528)