cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
ricardosanchezm
Level: Powered On

Issue while record form responses in SharePoint

Hi folks,

 

When ussing the template "Record form responses in SharePoint" to collect data like Username name, email and department to match them again the current values in Active Directory I'm getting additional and strange values in my tests.

 

The steps are the following:

 

  1. Users access the microsoft forms link we send them.
  2. User fill the field and send the form.
  3. Flow runs and insert data in a sharepoint list.
  4. We are getting the 3 records instead of 1 as I show you in the next image (the middle record is the correct one and the expected one)

1.png

I have checked  the flow output and there are no sight of the "asd" values. Also the "correct" record is duplicated but with missing fields like "Apellidos de Forms"

 

My Form is the following:

 

2.png

 

Do you have any idea what could be happening?

 

Regards,

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Issue while record form responses in SharePoint

 

Hi @ricardosanchezm ,

 

It seems that your configuration is correct.

Please check if you have created a Flow with similar logic before, so it has a similar effect.

You could try to delete these Flows that may have an impact, then recreate the same Flow from the blank to do the test.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Super User
Super User

Re: Issue while record form responses in SharePoint

@ricardosanchezm 

Can you post a screen shot of your Flow?  That will make it much easier to assist.


@ricardosanchezm wrote:

Hi folks,

 

When ussing the template "Record form responses in SharePoint" to collect data like Username name, email and department to match them again the current values in Active Directory I'm getting additional and strange values in my tests.

 

The steps are the following:

 

  1. Users access the microsoft forms link we send them.
  2. User fill the field and send the form.
  3. Flow runs and insert data in a sharepoint list.
  4. We are getting the 3 records instead of 1 as I show you in the next image (the middle record is the correct one and the expected one)

1.png

I have checked  the flow output and there are no sight of the "asd" values. Also the "correct" record is duplicated but with missing fields like "Apellidos de Forms"

 

My Form is the following:

 

2.png

 

Do you have any idea what could be happening?

 

Regards,


 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
ricardosanchezm
Level: Powered On

Re: Issue while record form responses in SharePoint

Hi @ScottShearer ,

 

Of course here is my flow

flow.png

 

Regards,

Community Support Team
Community Support Team

Re: Issue while record form responses in SharePoint

 

Hi @ricardosanchezm ,

 

It seems that your configuration is correct.

Please check if you have created a Flow with similar logic before, so it has a similar effect.

You could try to delete these Flows that may have an impact, then recreate the same Flow from the blank to do the test.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

ricardosanchezm
Level: Powered On

Re: Issue while record form responses in SharePoint

Hi @v-bacao-msft ,

 

I deleted the sharepoint list and the flow,  created from zero again and the issue is no more there.

 

Thanks for your help.

 

Regards,

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Users online (4,909)