cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
udayrajanand
New Member

Issues with connections while sharing flow

I have created a flow using my login where I have added some connections. This is a flow using the 'For a selected item' Sharepoint manual trigger. The subsequent actions on the flow require emails to be sent. And I have added connections so that those emails go from another service mailbox (orders@parijat.in)

udayrajanand_0-1627546353748.png

This has been done for all emails in the flow

The flow will be triggered from the sharepoint list by another user (pankaj.k@parijat.in)

I have shared the flow with Pankaj.k@parijat.in as well as orders@parijat.in 

udayrajanand_3-1627546539972.png

 

When I trigger the flow from Sharepoint the emails correctly go from orders@parijat.in as instructed in the connections

 

When Pankaj triggers the flow from sharepoint, the emails are getting triggered from pankaj.k@parijat.in instead of using the orders@parijat.in connection

 

When I login to power automate from pankaj.k@parijat.in i see that the in the action settings the connection on all emails is still set to order@parijat.in . I have also tried to reset that connection however email is still going from pankaj.k@parijat.in

Please help

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-LilyW-msft
Community Support
Community Support

Hi @udayrajanand 

Thanks for your posting.

If your email address is real, please pay attention to mosaic to protect your privacy.

About your issue, assume my 'Test2' address is your 'order' address.

You need to add 'pankaj.k' and 'order' in Run only users instead of Owners.

vLilyWmsft_0-1627635219090.png

And restrict this outlook connection use 'order'.

vLilyWmsft_2-1627636183824.png

Then no matter which of these three people triggers the flow, the email will be send by 'order'.

Hope the content above may help you.

Best Regards

If my solution helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
v-LilyW-msft
Community Support
Community Support

Hi @udayrajanand 

Thanks for your posting.

If your email address is real, please pay attention to mosaic to protect your privacy.

About your issue, assume my 'Test2' address is your 'order' address.

You need to add 'pankaj.k' and 'order' in Run only users instead of Owners.

vLilyWmsft_0-1627635219090.png

And restrict this outlook connection use 'order'.

vLilyWmsft_2-1627636183824.png

Then no matter which of these three people triggers the flow, the email will be send by 'order'.

Hope the content above may help you.

Best Regards

If my solution helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,097)