cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
stiwari
Frequent Visitor

Item Level Permissions not setting in sharepoint-online/Sharepoint 365 using Microsoft flow

I have a website name human resources under my company's SharePoint site. 

According to the suggested answer in

how to show items to users that made their requests but allow admins/managers to view all items in S...

and

http://www.ktskumar.com/2017/01/access-sharepoint-online-using-postman/

I was able to get the access token, client id and client secret using Postman.

Now that I am trying to use them in HTTP connector of Microsoft Flow as stated in these:

https://praveensharepointknowledgebase.wordpress.com/2018/04/23/item-level-permissions-using-microso...

https://noellawlor.wordpress.com/2018/01/18/setting-sharepoint-item-list-permissions-with-flow/

I find the way of getting Access token component as stated in both links doesn't work in my flow. I get unauthorized access all the time. I really have no idea why it is happening. I was able to fetch everything in Postman but it fails here in the Microsoft flow.

 

Get_AccessTokenGet_AccessToken

unauthorized.PNG

1 ACCEPTED SOLUTION

Accepted Solutions

Thank you. Yes, I got it now. It took me 4 days to figure this out. My URL should be encoded just like a normal URI. So for those characters that aren't alphabets or numbers(special characters), they should be encoded accordingly as shown in the below link and that worked.

https://sharepointmadeeasy.blogspot.com/2018/02/microsoft-flow-http-rest-api-invalid.html

 

View solution in original post

3 REPLIES 3
v-yamao-msft
Community Support
Community Support

Hi @stiwari ,

 

Please make sure the URL and the info included in the body text are correct.

 

I have seen a thread on Authentication in HTTP action in flow for your reference:

https://powerusers.microsoft.com/t5/General-Discussion/Authentication-in-Http-Action-in-Flow/td-p/13...

 

From the thread we know that “HTTPs works for the HTTP action card, but it may require that the https endpoint is serving an SSL cert that matches the hostname”.

 

Please check the thread for more details.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thank you. Yes, I got it now. It took me 4 days to figure this out. My URL should be encoded just like a normal URI. So for those characters that aren't alphabets or numbers(special characters), they should be encoded accordingly as shown in the below link and that worked.

https://sharepointmadeeasy.blogspot.com/2018/02/microsoft-flow-http-rest-api-invalid.html

 

Hi @stiwari ,

 

Thanks for updating.

 

Glad to hear that you have figured it out.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (2,791)