cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Link Not Working in the Flow Approval Email

We have a approval flow based on SharePoint List where we have added the link of Item in the email body. The expectation is, user should be able to open the item by clicking to the link. But as can be seen from the below image, when user clicks on the link, nothing happens. If we click on 'Show Original Message' then we get the link which is working, but it is complicated to explain the user to expand the message and do the same. Can anyone please help that how to fix this and can open the item by directly clicking on to the main email body?
6 REPLIES 6
Highlighted
Dual Super User
Dual Super User

Re: Link Not Working in the Flow Approval Email

What email application are you using?  This is normally a problem with a slightly older or non-standard email client.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Advocate I
Advocate I

Re: Link Not Working in the Flow Approval Email

Hi @Pstork1 ,

 

Yes I am using Outlook 2016. You rightly said. If I open the approval email in Outlook Web Access, i am able to click on the link and it is working perfectly fine. Only the issue is with Outlook. Best if you can suggest any solution for the same.

Highlighted
Dual Super User
Dual Super User

Re: Link Not Working in the Flow Approval Email

Unfortunately, if you are using Outlook 2016 the only real solution is to upgrade to Outlook 2019 or Outlook Pro Plus from Office 365.  Previous Office applications always have some issues with integration.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Advocate I
Advocate I

Re: Link Not Working in the Flow Approval Email

It will take some time to upgrade it to the newer versions. Any workaround till then?

Highlighted
Dual Super User
Dual Super User

Re: Link Not Working in the Flow Approval Email

The only other real workaround is either tell people to use Outlook Web Access or show them how to access the original mail item.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Advocate I
Advocate I

Re: Link Not Working in the Flow Approval Email

Well, its ok then. Many Thanks @Pstork1 for your help.

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (7,862)