cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

MS Flow Not Triggered on Create Of Dynamics Record (Email entity as well as Attachment entity)

I have a Flow that is triggered when a Dynamics record is created (Email entity), and another Flow that is triggered when an Attachment entity is created, but they never get triggered, run history is empty for both. I tried by manually creating Email activities and then attach multiple files to them.

I have other Flows that are triggered when a Note entity is created and they work fine.

When An Email Is Created.pngWhen An Attachment Is Created.png

Any suggestion?

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: MS Flow Not Triggered on Create Of Dynamics Record (Email entity as well as Attachment entity)

Hi @Anonymous ,

 

I tested Email Messages entity on my side and created a record using Create a new record action. The associated trigger can be triggered normally.

Please try to update the Connection and re-test, and wait a while, I found that the response is a bit slow, but trigger still work fine.

Image reference:

48.PNG46.PNG47.PNG

 

Please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Anonymous
Not applicable

Re: MS Flow Not Triggered on Create Of Dynamics Record (Email entity as well as Attachment entity)

Hi Barry Cao,

 

Thanks for the reply, i tried to change the Connection (by changing the "Organization Name" of the trigger) to other instance and change it back, then create an email record to test, it fired for the first time....and only for the first time. It never got triggered again for subsequent email records. Seems like the stability is not good yet.

 

I will try this method on the "Attachment" entity and update here.

Highlighted
New Member

Re: MS Flow Not Triggered on Create Of Dynamics Record (Email entity as well as Attachment entity)

Did you resolve this for the attachment entity?  I too cannot seem to trigger off of a record created trigger on this entity. Any update here would be great. 

 

Frank 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Users online (7,465)