cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Microsoft Form Flows are hanging on Apply to Each

Hey Everyone,

 

I use a Microsoft Form to trigger our IT Outage notificaiton process. To oversimplify, It sends an email, and adds the information to a SPO List. However today the flow kept hanging on "Apply to Each" (the step that automatically gets put in when using Form response details). The flow that normally took 15 seconds would continue to run after 20+ minutes. I would manually cancel them and after 4 unsuccessful attempts I finally quit.

 

So I decided to start from scratch and use a new Microsoft Form with a new SPO list to see what is going wrong and EVEN THAT isn't working. I've included a screenshot of the simplified version that isn't even working.

 

So I am curious whats going wrong with Microsoft Forms and Flow.

 

Flow failure.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate I
Advocate I

Re: Microsoft Form Flows are hanging on Apply to Each

I posted this in another thread. Apparently yesterday there was a ubiquitous issue with Form flows. What I did to fix it was go to each Action/Trigger and added a "New Connection".

View solution in original post

8 REPLIES 8
Highlighted
New Member

Re: Microsoft Form Flows are hanging on Apply to Each

Noticed the same issue today.

Highlighted
New Member

Re: Microsoft Form Flows are hanging on Apply to Each

Hi,

I'm having the same problem. Flows are failing at "Get response details" from Forms. These were all working well until yesterday. Any ideas?

 

 

Highlighted
Advocate I
Advocate I

Re: Microsoft Form Flows are hanging on Apply to Each

I posted this in another thread. Apparently yesterday there was a ubiquitous issue with Form flows. What I did to fix it was go to each Action/Trigger and added a "New Connection".

View solution in original post

Highlighted
New Member

Re: Microsoft Form Flows are hanging on Apply to Each

Thank you! This worked like a charm. I fixed the first flow and all the others are now working with the new connection as well.

 

Pfew!

Highlighted
Regular Visitor

Re: Microsoft Form Flows are hanging on Apply to Each

I know this thread is almost a year old, but hoping someone is still unknwoingly subscrubed to it...

 

I'm having this same issue right now. Can someone explain in a little more detail how you fixed it?

Highlighted
Advocate I
Advocate I

Re: Microsoft Form Flows are hanging on Apply to Each

I went to each connection on each action and clicked "Add New connection"

Highlighted
Regular Visitor

Re: Microsoft Form Flows are hanging on Apply to Each

Looks like that's no longer solving the problem. My flow is triggered from a Form submission, so I deleted the connection to forms compeltely, then reconnected. Still runs indefinitly, despite usually completeing in about 5 seconds...hooray.

Highlighted
New Member

Re: Microsoft Form Flows are hanging on Apply to Each

Hello,

 

I am having this issue where the "apply each" comes up when I do not need it.

 

I have tried adding a new connection to each action/trigger and still no resolve.

 

Is there another solution?

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Users online (6,050)