cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
CedricCosta
Regular Visitor

Move file in Sharepoint - Error: Bad Request

Hello Community,

I'm experiencing an error while moving a file in my Teams Sharepoint folder, which you can see below:

Screenshot_1.png

 

It says: 

 

{
  "status": 400,
  "message": "An item with the same key has already been added. CallStack --    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)\r\n   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)\r\n   at Microsoft.SharePoint.Deployment.MetaInfoHandler.Add(MetaInfoProperty property)\r\n   at Microsoft.SharePoint.Deployment.FileSerializer.HandleMetaInfo(ExportObjectManager objectManager, SPWeb parentWeb, Object metaInfoObject, SerializationInfo info, Guid listID, Guid itemID, String itemETag)\r\n   at Microsoft.SharePoint.Deployment.FileSerializer.GetDataFromDataSet(Object obj, SerializationInfo info, StreamingContext context)\r\n   at Microsoft.SharePoint.Deployment.DeploymentSerializationSurrogate.GetObjectData(Object obj, SerializationInfo info, StreamingContext context)\r\n   at Microsoft.SharePoint.Deployment.XmlFormatter.SerializeObject(Object obj, ISerializationSurrogate surrogate, String elementName, Boolean bNeedEnvelope)\r\n   at Microsoft.SharePoint.Deployment.XmlFormatter.Serialize(Stream serializationStream, Object topLevelObject)\r\n   at Microsoft.SharePoint.Deployment.SPExport.SerializeObjects()\r\n   at Microsoft.SharePoint.Deployment.SPExport.Run()\r\nclientRequestId: 82dfd7e6-4c96-4e82-b298-bba799c58ff8\r\nserviceRequestId: 82dfd7e6-4c96-4e82-b298-bba799c58ff8"
}

 

 

I can't figure it out why there should be in item with the same key before the file even gets copied into the folder.

A few connectors before the error occures I also move a file and this works just fine.. 
Screenshot_2.png

 

I hope someone can help me figure it out.

Sincerely,
Cedric

3 REPLIES 3
ChristianAbata
Community Champion
Community Champion

mmm @CedricCosta  this could be becouse you have a column list that allows unique vales, Please try to chacnge the config of your sharepoint list.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Could you please be a bit more specific on what to change? I found the column settings of my sharepoint folder but all settings are the default ones. Do I have to add a column and force it to have unique values?

 

Here the default columns (it's in german):

Screenshot_1.png

@CedricCosta  what you need to chacnge is thisunique.png



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

New Process Advisor Capabilities carousel.png

Read the blog for the latest news

Read the latest about new experiences and capabilities in the Power Automate product blog.

PA Survey Carousel Image.png

We want to hear from you!

If you are a small business ISV/Reseller, share your thoughts with our research team.

AI Builder AMA June 7th carousel (up on May 25th, take down June 8th) (1).png

'Ask Microsoft Anything' about AI Builder!

The AI Builder team invite you to ask questions and provide helpful answers at our next AMA.

Users online (1,631)