cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
KenH
Level: Powered On

Multiple Recipients not receiving email, semicolon is used

I have a flow set up for when an item is modified in sharepoint to send an email to 2 users based on 2 fields in the SP List that include the users by People Lookup.  The first user is receiving the email and the second is not.  I have used the semicolon and verified the email address is correct and nothing is blocking emails being received for this user.

 

I even went so far as to recreate the email in SharePoint Designer 2013 and it worked there, so I am not sure what I am missing or what is the issue with the Flow I created.

 

Any help or suggestions is appreciated.


Thanks!

3 REPLIES 3
Community Support Team
Community Support Team

Re: Multiple Recipients not receiving email, semicolon is used

Hi Ken,

 

Could you show me how is your SharePoint list configured? I am not sure with this “People Lookup”.

 

So I created a simple list looks like below for testing:
email1.PNG
Then created a flow to send email to Person1 and Person2 when items are modified, a screenshot of my flow:
email2.PNG
I ran the flow for several times, email can be sent to both two email addresses.

email3.PNG

 

If convenience, please also show your flow configuration for better understanding.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
KenH
Level: Powered On

Re: Multiple Recipients not receiving email, semicolon is used

Hi Mabel,

 

So here is how I am set up.

 

2017-02-09_07h59_43.png

 

The highlighted fields are the two SharePoint User Lookup fields I am using for email and the field in the Red Box is my condition for the Flow, which is a Date/Time type.  Below is how I have the Flow set up.

 

2017-02-09_08h06_11.png2017-02-09_08h06_42.png

 

I intended the Flow to send the email only when the value of the QA Completion Date field is not blank.  It will send the email to the Ops Manager, but not to the Assigned Developer.  I tried moving the Assigned Developer to the Cc area as well but still no luck.  I was able to recreate this in SharePoint Designer 2013 and it sent both emails with no issues...which is what led me to come here and follow up on if this was an existing issue with Flow or if there was something I was doing incorrectly.

 

Thanks!

Ken Hopper

Community Support Team
Community Support Team

Re: Multiple Recipients not receiving email, semicolon is used

Hi Ken,

 

Thanks for updating.
I am afraid that currently we are not able to use flow to check if an item in a SharePoint list is existing or not. So “Ops Manager” can also receive an email every time when an existing item is modified.


May I suggest you submit an idea about this issue on Flow ideas Forum, I will suggest other customers who have the same request to vote this idea. The link of Flow Ideas Forum is:
https://powerusers.microsoft.com/t5/Flow-Ideas/idb-p/FlowIdeas


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons in April

Read the announcement for more information!

firstImage

Better Together Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Kudoed Authors
Users online (3,249)