cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

No row was found with Id '1', however I am checking against "Data ID" and not "Id"

I have a iterating primary ID being generated programmatically vial variables and expressions, entering static integers into the column, Data ID.

Here is the set-up in Flow:

 
 

 

 

setup for no row was found with id 1.png

 

 

 

When I attempt an "Apply to each" identifying the Key Column as "Data ID" and the key value as the current value of "Data ID," I see in the run report that Data ID was the Key Column, the Key Value used in the first iteration was "1" then get the error message 404: No row was found with Id '1.'

 

 

error report no row was found with id a.png

To my inexperienced eye, it looks like:

I am asking flow to look for a row with "Data ID" to be equal to "1" then

Flow goes and tries to find a row where "Data ID" equals "1" and then, for some reason, says that

it can't find a row with "Id" equal to "1" which is a problem, for some reason.

How do I make Flow look for a row to update with "Data ID" equal to 1?

 

Yes, Data ID = 1 exists
Data ID 1 exists.png

 

What key concept am I missing on this? Or, is this yet another one of the many bugs in Flow?

 

Thank you in advance for your help; it is very appreciated.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: No row was found with Id '1', however I am checking against "Data ID" and not "Id"

Hi @BenDonahue,

 

I try to create an Excel file and structure a Flow as you show, but it works well.

Is there still a problem with your Flow? maybe it's a temporary problem.

Annotation 2020-08-05 101933.jpg

 

Annotation 2020-08-05 101934.jpg

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

7 REPLIES 7
Highlighted
Super User II
Super User II

Re: No row was found with Id '1', however I am checking against "Data ID" and not "Id"

Hello @BenDonahue 

Please check your value that you use in the Key field! Does it contain a space/blank after the number?

I can recreate your issue when my Key is "1 " <- there is a space after the 1 digit!

Kind regards, John

Highlighted
Community Support
Community Support

Re: No row was found with Id '1', however I am checking against "Data ID" and not "Id"

Hi @BenDonahue,

 

I try to create an Excel file and structure a Flow as you show, but it works well.

Is there still a problem with your Flow? maybe it's a temporary problem.

Annotation 2020-08-05 101933.jpg

 

Annotation 2020-08-05 101934.jpg

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Super User II
Super User II

Re: No row was found with Id '1', however I am checking against "Data ID" and not "Id"

Hello @BenDonahue 

It could actually be that you have the space/blank in the Key Value field, either before or after your dynamic value!

Kind regards, John

Highlighted
Community Support
Community Support

Re: No row was found with Id '1', however I am checking against "Data ID" and not "Id"

Hi @BenDonahue,

 

Has your problem been solved?
If your problem has been solved, You could go ahead and mark the post as solved by clicking “Accept as Solution” so that this thread will be marked for other users to easily identify!

Best Regards,
Community Support Team _ Lin Tu

Highlighted
Advocate II
Advocate II

Re: No row was found with Id '1', however I am checking against "Data ID" and not "Id"

As with many aspects of Flow and Power Automate, this was a temporary one that arose from the glitchy nature of Power Automate.

 

Power Automate, a platform I need to master to excel in my career, is extremely unstable, glitchy, buggy and highly unreliable. Sometimes conditional blocks evaluate opposite of what they are supposed to.

Sometimes my expressions are not accepted, only to have them accepted again if I immediately click "Update" again.

Sometimes my expressions do not update when I click " Update."

Sometimes the dynamic content that should be available in the Dynamic Content list is no there and I have to hard refresh to gain access to this data.

Sometimes Excel will over-write all my formulas with whatever formula was last entered, and even top-level Microsoft Support was not able to address that issue (My support rep was able to bypass that issue by addressing the data differently and in closer adherence with Best Practices)

 

And, sometimes not. All this comes together to set the stage for unpredictable results gleaned from unstable components with unreliable integrations between them.

Highlighted
Advocate II
Advocate II

Re: No row was found with Id '1', however I am checking against "Data ID" and not "Id"

 
Highlighted
Advocate II
Advocate II

Re: No row was found with Id '1', however I am checking against "Data ID" and not "Id"

 

Helpful resources

Announcements
secondImage

August 2020 CYST Winners!

Check out the winners of the recent 'Can You Solve These?' community challenge!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (3,647)