cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Adomo
Frequent Visitor

Please help - Forms Not triggering flow 3-Dec-2020

I'm not sure if this is a systematic failure, or am I'm doing something wrong? none of my flows are triggering, just started this morning.

 

I have been using this flow for 2 months with no issues.

Adomo_0-1607010834985.png

it worked at 8:22am this morning and has stopped working or very delayed...? I created a test flow for a simple email response from a MS forms and it didn't go through.

 

here is the test the history doesn't even say failed...? it wont initiate the process...

Adomo_1-1607010976741.png

 

anyone else experiencing this problem?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
YashPatel
Microsoft
Microsoft

We are investigating this issue right now. This seems to be a non-isolated report. I will post updates here as I receive them.

Apologies for the inconvenience this issue may cause.

 

11:15am CST update: We have raised this with the product group and have engaged the right resources for investigation. I will update again as I receive more updates. 

12:05pm CST update: the product team is still investigating this issue. There will be a Service Health update posted shortly as well.

2:15pm CST update: we've restarted some services and responses should now slowly start flowing in. We do not expect missed responses to be processes by Flow. 

Final update 3:00pm CST: All Microsoft Forms responses should flow into Microsoft Power Automate successfully now. Please follow SHD# FL228460 in the M365 Service Health Dashboard for a full RCA in the next few days. 

For users with missed Forms responses, here is one possible way to processes these responses:

1. Duplicate the original flow;
2. Replace the trigger with "Manually trigger a flow", add a number input;
3. In "Get response details" action, replace the field in "ResponseId" with the number input of above trigger, and click "Save".
4. Then click "Run". In the "ResponseId" field, you can enter the ID of the responses which didn't trigger original flow.
5. The response ID can be found on form's "Responses" page, via exported Excel, or click "View results" button.

View solution in original post

17 REPLIES 17
cybermikeb
Regular Visitor

I'm having the same issue with my flow too. Everything was working until like 2 hours ago.

joelem
New Member

I am seeing the exact same thing. Seems isolated to Microsoft Forms and Power Automate. Mine triggers on a form completion to post into Teams. Everything is just timing out and never running, but if I test with older form data it works without issue.

Adomo
Frequent Visitor

As you mention if I test the older data it works. but for whatever reason its not picking up new submissions. I just had pending approvals that went through and completed the flow but new form submissions are not being picked up... I can only assume they are all delayed and will come in later.. really hope so. when i download the excel sheet from my MS forms they are updating there correctly... just not activating the flows. all my connections are active and good to go.

YashPatel
Microsoft
Microsoft

We are investigating this issue right now. This seems to be a non-isolated report. I will post updates here as I receive them.

 

Apologies for the inconvenience this issue may cause.

 

11:15am CST update: We have raised this with the product group and have engaged the right resources for investigation. I will update again as I receive more updates. 

Anonymous
Not applicable

To echo the same sentiment - form responses i can see in the form 'view results' page has new entries but the flow has not been triggered. 

The only potential difference to the above is that the flow triggers perfectly when I submit the form response myself. 

YashPatel
Microsoft
Microsoft

We are investigating this issue right now. This seems to be a non-isolated report. I will post updates here as I receive them.

Apologies for the inconvenience this issue may cause.

 

11:15am CST update: We have raised this with the product group and have engaged the right resources for investigation. I will update again as I receive more updates. 

12:05pm CST update: the product team is still investigating this issue. There will be a Service Health update posted shortly as well.

The same happens to me.

All my flows that are triggered with a Form are not working.

Those that are manual or schedule activation

kblankenship35
New Member

Any updates to this issue? Same thing has happened to us, starting between 9:00 and 10:00 CST this morning.

Adomo
Frequent Visitor

Painful... I hope its just a server issue and all my forms are being "held" and not cancelled...

JR1
Regular Visitor

Thank you for working on this issue. It is intermittently working on my end. Not 100% like normal.

Calebm
Regular Visitor

I am also experiencing this issue, commenting to add another voice and hopefully receive updates on the situation.

YashPatel
Microsoft
Microsoft

We are investigating this issue right now. This seems to be a non-isolated report. I will post updates here as I receive them.

Apologies for the inconvenience this issue may cause.

 

11:15am CST update: We have raised this with the product group and have engaged the right resources for investigation. I will update again as I receive more updates. 

12:05pm CST update: the product team is still investigating this issue. There will be a Service Health update posted shortly as well.

2:15pm CST update: we've restarted some services and responses should now slowly start flowing in. We do not expect missed responses to be processes by Flow. 

YashPatel
Microsoft
Microsoft

We are investigating this issue right now. This seems to be a non-isolated report. I will post updates here as I receive them.

Apologies for the inconvenience this issue may cause.

 

11:15am CST update: We have raised this with the product group and have engaged the right resources for investigation. I will update again as I receive more updates. 

12:05pm CST update: the product team is still investigating this issue. There will be a Service Health update posted shortly as well.

2:15pm CST update: we've restarted some services and responses should now slowly start flowing in. We do not expect missed responses to be processes by Flow. 

Final update 3:00pm CST: All Microsoft Forms responses should flow into Microsoft Power Automate successfully now. Please follow SHD# FL228460 in the M365 Service Health Dashboard for a full RCA in the next few days. 

For users with missed Forms responses, here is one possible way to processes these responses:

1. Duplicate the original flow;
2. Replace the trigger with "Manually trigger a flow", add a number input;
3. In "Get response details" action, replace the field in "ResponseId" with the number input of above trigger, and click "Save".
4. Then click "Run". In the "ResponseId" field, you can enter the ID of the responses which didn't trigger original flow.
5. The response ID can be found on form's "Responses" page, via exported Excel, or click "View results" button.

View solution in original post

OlgaAnto
New Member

This issue caused a serious impact. User responses were not updated into the SharePoint list from MS Forms. By taking the list as the data, those users were escalated. Later one of the user shared a screenshot that he has submitted it. Then technical team checked the form responses and found the above users were already submitted it. I think Microsoft need to be more careful with these uptime and the performance. This is very important. 

Hi team,

 

I am experiencing the same problem as described above where my flow as stopped triggering from form submissions on a business critical process. Can you please investigate if these is occurring again and work to resolve? 

kmccahan
New Member

Hi All,

 

I am experiencing the same problem as described above. My PowerAutomate flow does not trigger with Form submission. This was working fine yesterday and does not seem to be an issue with the flow. Can you check to see if this issue has recurred and what can be done to fix?

One of our customer is complaining about this issue, 

The outage is problematic so they would like to know why it is happening (even infrequently) and whether we can avoid it in the future or solved permanently 

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power Automate User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (76,019)