cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dougallen
Level: Powered On

Populate a Word Document Breaks, shows numbers??

Ok this is a really strange issue and extremely frustrating as its causing me a large amount of re-work.  I had a flow working fine, it has a switch with 15 options, in each one populating a Word document then creating it (different Word template).  It's been working fine for a couple months.  I was enhancing the Flow in a different area and hit Save, and the checker starting crying about this original populate Word actions.  

 

Annotation 2019-08-15 094913.jpg

 

Huh???  I looked at my Word templates it calls in the library and they haven't been modified since June so I know someone didn't change anything, it's something in the action.  I open that Word template and find the only 2 places where that data shows, and the Plain text controls show their names and look fine.  If I add a another "populate Word" action to the SAME Word template, these numbers don't show anywhere and it looks fine.  I believe my fix is then to just delete and re-create this action, but seriously?  This is a couple hours of work and it doesn't help I can't copy and paste inside a switch!  

 

It's just very concerning that Flow out of nowhere loses its connection to the Word template, or is unable to read it right.  What if the next time I edit the Flow it breaks again?  I understand its still Preview but ... any idea?  To me it just seems once it loses it, I have no choice but to delete and re-create the action.  

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Populate a Word Document Breaks, shows numbers??

The problem is that the Word "Populate a template" action recently moved from "preview" to "premium".  So its not preview anymore.  I suspect that change is what is causing the issue.  Since the action has been reclassified I'm sure its a new version, even if it takes the same parameters.  That may be what is causing your issue.  You may have to remove and re-add the action to refresh it properly.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

6 REPLIES 6
Super User
Super User

Re: Populate a Word Document Breaks, shows numbers??

The problem is that the Word "Populate a template" action recently moved from "preview" to "premium".  So its not preview anymore.  I suspect that change is what is causing the issue.  Since the action has been reclassified I'm sure its a new version, even if it takes the same parameters.  That may be what is causing your issue.  You may have to remove and re-add the action to refresh it properly.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

dougallen
Level: Powered On

Re: Populate a Word Document Breaks, shows numbers??

Paul,

 

Well that is unfortunate timing!  Sure wish I would have waited a day to build all my actions Smiley Happy, now I get to redo them all.  Hopefully that was the issue and it won't happen again.  Thanks for the pointer.  

dougallen
Level: Powered On

Re: Populate a Word Document Breaks, shows numbers??

@Pstork1 The action still shows Preview for me.  When did this go GA?  

Super User
Super User

Re: Populate a Word Document Breaks, shows numbers??

Its a recent change, probably in the last week or so.   Not sure why it would affect you if it hasn't hit your tenant yet.  But you can see it clearly shows as Premium in my tenant

 

screenshot.png



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
dougallen
Level: Powered On

Re: Populate a Word Document Breaks, shows numbers??

I see that too, but the second after that, it still shows Preview in the header.  It's always been a Premium action, so not sure what you are saying changed. 

Super User
Super User

Re: Populate a Word Document Breaks, shows numbers??

Not sure when the premium labeling hit, but there were changes made to this action recently.  The move to premium was one of those changes, because there was a fairly lengthy discussion between the MVPs on the call and the Microsoft representative who announced the change.  For Example, the Excel Online connector is still standard.  Its only the Word connector that has gone premium.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020.

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Users Online
Currently online: 77 members 3,737 guests
Please welcome our newest community members: