cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hiccup
Advocate II
Advocate II

PowerApps/Flow "InvokerConnectionOverrideFailed" when trying to run Flow

Hello

 

I've been having endless problems today when I try to run Flows within PowerApps.

I have a flow which calls a stored procedure and returns the result to PowerApps:

hiccup_0-1615481701975.png

The flow runs perfectly fine when I run it within the 'Edit' client.

However, when I try to run the flow on any device (tablet, mobile, powerapps desktop app), I get the following error:

"[FLOW NAME].Run failed: {"code": "InvokerConnectionOverrideFailed", "message": "Failed to parse invoker connections from trigger 'manual' outputs. Exception: Could not find any valid connection for connection reference name 'shared_sqldw' in APIM tokens header."}

When I look at the Run History of the flow, I see no evidence of it trying to run from the device - only the successful Edit client runs.

 

So far, I've tried the following solutions:

  1. Removing and readding the flow into the app.
  2. Creating the flow again from scratch
  3. Recreating the SQL connection - even tried creating a brand new user in the database
  4. Creating a new blank app, adding in the flow, same issue.

Unfortunately, none of the above has worked and I'm running out of ideas 😞 

 

This is now happening across multiple flows and multiple apps. Everything is working perfectly as expected in the Edit client, however as soon as I try to use the app externally it all breaks.

Also these are not new flows - I have been successfully using these flows over the past week and not had this issue until today.

 

If anyone could help, it would be hugely appreciated!

Thank you 😊

 

6 REPLIES 6
DavidPrague
Frequent Visitor

I have the same issue! I am also using SQL connector and when i delete SQL query, flow starts to work. Also when i trying in Edit client, it is ok, but when external user hit the button, that error message will show up.

 

hiccup
Advocate II
Advocate II

Morning,

 

Just to give a quick update...

Since posting this yesterday, I've tried the following:
1. Changing the Azure SQL connection on the flow to a SQL server connection, removing and readding the flow to the app, same issue.

2. I tried creating a brand new stored procedure on a completely separate database, separate from everything I've done so far. Created a brand new flow which connects to this new SP, using a new user connection, created a blank app, added the new flow to the app, same issue.

 

Please please could someone help me with this asap as it's stopping me from being able to work!

Thank you @DavidPrague for letting me know you're having the same issue - I'm so glad it's not just me!

DavidPrague
Frequent Visitor

This must be problem at Microsoft / Power Apps side, or maybe a license problem, but in any other topic no one from the creators write the reason, why this is happening to us. My bussiness app is now blocked and i dont know how and when i will be able to fix it. Please ASAP fix.

Mark-Shenouda
Microsoft
Microsoft

@hiccup 
Hope you are well,
are you still receiving this error ?

Hi Mark,

 

I've just tried my app now and I'm still getting the same error.

Any way you can advise would be fantastic.

 

Thanks! 🙂 

Morning,

 

I've just tried again this morning and seems to be working fine!

I did have to remove the flows from the app and re-add them again.

Fingers crossed it's all okay now...!

 

@DavidPrague Hopefully yours is working okay too?

 

Thanks! 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,112)