cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
W4W
New Member

Recent error with flow and Im a total noob at this

Hi, hope this is even the right place to ask for advice. I just took over this Sharepoint and I have no experience with it. One of our flows running an email pulling data from an internal list stopped working and I have no idea where to even start as I didn't make any changes so don't know what could have caused it to fail. 

Here is what it said

Error Details

The execution of template action 'Apply_to_each_3' failed: the result of the evaluation of 'foreach' expression '@items('Organizes_values_and_inputs_them_in_table')?['Job_x0020_Location']' is of type 'Null'. The result must be a valid array.
Start time
Nov 5, 12:07 PM (24 seconds ago24 sec ago)
Duration
00:00:22
Error
Action 'Apply_to_each_3' failed
Error Details
 
 
11 REPLIES 11
ScottShearer
Super User
Super User

@W4W 

Flow is complaining that the Job location column is empty.

Can you post a screen shot of your Flow in edit mode as well as a screen shot of a run that shows the error?

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
W4W
New Member

Ok hope this is what you meant 🙂 

scrnli_11_5_2021_12-44-11 PM.png

W4W
New Member

scrnli_11_5_2021_12-51-09 PM.png

W4W
New Member

@ScottShearer Sorry Im also first time here so learning curve

v-JessicaG-msft
Community Support
Community Support

Hi @W4W ,

 

Do you want to use flow to pull data from an internal list?

 

The flow error message that the Job location column is empty. The reason for this error may be that the items obtained from the SharePoint list have a null value, or the created variable may have a null value. Could you show more details?

vJessicaGmsft_0-1636540529457.png

vJessicaGmsft_1-1636540538972.png

vJessicaGmsft_2-1636540549948.png

 

Best regards,

Jessica Gu

W4W
New Member

Hi Jessica,

Yes I am trying to pull from an internal list. I made no changes so am unsure how it suddenly stopped working. When you say it's empty, none of the data columns are empty nor is the category box. What should I share with you? Sorry as much info as possible needed as I don't have the knowledge of this yet. Just began watching videos on it. Thank you so much @v-JessicaG-msft 

 

@W4W 

The Flow loops through all items in the list - are there any items where Job Location is empty/null?

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Ok here is what you show to see. I tried searching the List and found one that didn't have a Job Location. I deleted the entry but still it isn't running. Here is a screenshot plus the Raw Input data from Get Job Announcements South. You show the String and Variable Value Array but in mine I can't seem to expand those?

 "method""get",
    "queries": {
        "$filter""Job_x0020_Location eq 'Southern Nevada' and Created ge '2021-11-06T18:30:55Z'",
        "view""8324ecf5-dfb6-4559-b1af-a4cca8a7a7b2"
    },
    "path""/datasets/https%253A%252F%252Fworkforwarriors.sharepoint.com%252Fsites%252FWorkforWarriorsNV/tables/e9ce676b-1871-4ce8-9c1f-2e10b97b9196/items",
    "host": {
        "api": {
            "runtimeUrl""https://unitedstates-002.azure-apim.net/apim/sharepointonline"
        },
        "connection": {
            "name""/providers/Microsoft.PowerApps/apis/shared_sharepointonline/connections/975a69f8dffe4103b639af609556f928"
        }
    },
    "authentication": {
        "scheme""Key",
        "parameter""*sanitized*",
        "type""Raw"
    }
}
scrnli_11_10_2021_10-54-09 AM.png
ScottShearer
Super User
Super User

@W4W 

Did it fail in the same place and for the same reason?  Is the error message the same?  If not, can you post?  If it did not fail in the same place, please provide screen shot of the run showing where it failed.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
W4W
New Member

Yes it is the same. No change at all. I did notice in the Edit screen that the Variable in that box where it fails is set to Null but I believe thats who we wanted it because thats how it has been running in the history of the versions I looked at. The report I posted above is after I removed the job that didn't have a location. The original post I made was before that list entry was deleted. @ScottShearer   Im making a copy now and with my zero knowledge lol Im trying to see what the differences are between the failed one and the last one that ran successfully. I so far see nothing at all. The list has no other errors that I can find by filtering through it under Job Location. 

W4W
New Member

@ScottShearer 

W4W_0-1636573125297.png

So is it saying this cannot be set to Null anymore ? If so, why all of sudden? 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Users online (1,182)