cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AneeqaPervaiz
Helper II
Helper II

Referencing Phone Call record from custom activity entity

Hello, 

 

I have created a custom activity entity - Call Attempt. I have a ribbon button on the Phone Call entity - when clicked, it creates a call attempt for the user and all these call attempts are shown in a subgrid on the original phone call. I also need to link the original phone call on the call attempt record. So these are the steps that I am following: 

1. User clicks on the Call Attempt button on the ribbon

2. A code runs which creates the call attempt record. 

3. The code takes the text guid of the phone call and sets it on the field in call attempt 

 

I created a power automate flow to run as soon the text guid is populated, then updates the record to populate the phone call lookup field in call attempt. So in the lookup field, I am using the syntax phonecalls(TEXT_GUID_DYNAMICVALUE). 
But I keep getting this error. 

AneeqaPervaiz_0-1612469511503.png

I have tried lots of ways to reference this. /phonecalls/TEXT_GUID. Also hardocded the guid. Used older CDS connector to update record. All to no avail. 

 

Is there another way to reference an OOB activity entity in a custom activity entity?

 

Any help would be appreciated. 

@abm @Pstork1 

 

Thanks. 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hey @abm 

 

Turns out an identifier for activity entities is different. For any custom activity entity, the identifier is ACTIVITY, not the name of the entity like we have for others, eg identifier for phonecall is phonecall, but for any custom activity entity, it is activity. So in my update record, it should have been this;

AneeqaPervaiz_0-1612908303304.png

In my case, I had a boolean field called Call Attempt, and I kept putting that as an identifier - no surprises that I kept getting an error. 

 

Thanks for all your help. 

 

View solution in original post

9 REPLIES 9
abm
Super User
Super User

Hi @AneeqaPervaiz 

 

Try the below

 

image.png

 

In my test I have created a phone call in my flow and next step I used my custom entity lookup set as above.



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Thanks for the reply @abm 
But it still gives the same error. Please find the screenshot below. 

AneeqaPervaiz_0-1612532677391.png

The boxed field is the one I am trying to update to a link. 

Hi @AneeqaPervaiz 

 

Ok what you need to do is try the below List rows filter using activityid. Next step you can map the Phone Call unique identifier (GUID) like I did earlier.

 

image.png



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

I tried it both ways: ActivityID hardcoded, and a dynamic value - both yield the same results. 

AneeqaPervaiz_0-1612534458570.png

 

abm
Super User
Super User

Hi @AneeqaPervaiz 

 

Could you show me your mappings? Have you got any other mappings in that update? Please show a screenshot. Also is that trigger is when a phone call record is updated? In that case you don't need the list. You can get the Id directly from the trigger.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
AneeqaPervaiz
Helper II
Helper II

Hey. 

 

So the trigger is when the 'Call Attempt' entity record is created. A button on my phone call ribbon creates a record called Call Attempt. Call Attempt is a custom activity entity - only used with the phone call entity. 

 

So when the call attempt button in phone call is clicked, a call attempt record is created. And on the call attempt record, I need to link the original phone call. So the code which creates the call attempt record also updates a text guid of the phone call from where it was created. 

AneeqaPervaiz_8-1612541938739.png

So what I am having my power automate flow is to run whenever a call attempt is created and a text guid is populated. Then I want the original call attempt (a lookup field to phone calls) to populate with the link via the power automate flow. I have been doing this for another custom button as well where a phone call is created from phone call. That works perfect. 
But referencing the phone call from a call attempt is giving errors. 

AneeqaPervaiz_9-1612541965407.png

AneeqaPervaiz_15-1612542096161.pngAneeqaPervaiz_16-1612542108828.png

 

On my update record step, nothing else is being updated but the lookup link. 

AneeqaPervaiz
Helper II
Helper II

Hey @abm 

 

So the trigger is when the 'Call Attempt' entity record is created. A button on my phone call ribbon creates a record called Call Attempt. Call Attempt is a custom activity entity - only used with the phone call entity. 

 

So when the call attempt button in phone call is clicked, a call attempt record is created. And on the call attempt record, I need to link the original phone call. So the code which creates the call attempt record also updates a text guid of the phone call from where it was created. <image 1>

 

So what I am having my power automate flow is to run whenever a call attempt is created and a text guid is populated. Then I want the original call attempt (a lookup field to phone calls) to populate with the link via the power automate flow. I have been doing this for another custom button as well where a phone call is created from phone call. That works perfect. 
But referencing the phone call from a call attempt is giving errors. <Image 2,3,4>

On my update record step, nothing else is being updated but the lookup link. Image 1.pngImage 2.pngImage 3.pngImage 4.png

Hey @abm 

 

Turns out an identifier for activity entities is different. For any custom activity entity, the identifier is ACTIVITY, not the name of the entity like we have for others, eg identifier for phonecall is phonecall, but for any custom activity entity, it is activity. So in my update record, it should have been this;

AneeqaPervaiz_0-1612908303304.png

In my case, I had a boolean field called Call Attempt, and I kept putting that as an identifier - no surprises that I kept getting an error. 

 

Thanks for all your help. 

 

View solution in original post

Hi @AneeqaPervaiz 

 

Glad to hear that its sorted now. That naming convention was misleading and of course for the activity entities identifier is always activity. Thanks for letting me know.



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Helpful resources

Announcements
Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Users online (1,500)