cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
YannisB
Frequent Visitor

SQL get rows emtpy

Hello all,

I have a recurring flow that

  1. get sharepoint list items
  2. deletes the items
  3. get rows from SQL
  4. inserts the sql rows into the sharepoint list

This flow on the get rows action returns an empty data set. There are no failed steps.

If I run this manually it completes without issue.

This flow used to run for many months without issue,

How could I trouble shoot such behaviour?

 

I have tried to run this 2 times per week hoping that the 2nd time it would work but alas..

2 REPLIES 2
SudeepGhatakNZ
Resident Rockstar
Resident Rockstar

@YannisB ,

What account is the flow running against, does it have access to the SQL table?

Did you investigate the flow run?

 

If my suggestion helped you, please give it a Thumbs up and mark it as a Solution so that it can benefit others in the community.
YannisB
Frequent Visitor

@SudeepGhatakNZ  could in theory the account be different when running automatically vs manually?

This is what the raw inputs from both runs (automatic and manual) show

{
    "host": {
        "connectionReferenceName""shared_sql_2",
        "operationId""GetItems_V2"
    },
    "parameters": {
        "server""default",
        "database""default",
        "table""[dbo].[PagiaCustomers]"
    }
}
 
 

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (1,964)