cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ullurr
Frequent Visitor

Saving email from shared mailbox to SharePoint list and Document Library

 

 

 

 

I am having issue is saving emails to email from shared mailbox to SharePoint list and Document Library

I having tried using existing triggers "When a new email arrives in a shared mailbox " and "Export Email" and "Create File "

When i run the Flow i get following Error 

 

{
  "error": {
    "code": "ErrorItemNotFound",
    "message": "The specified object was not found in the store., Can't connect to the mailbox of user Mailbox database guid: e698610c-520b-4c93-bb18-6e53c6d03324 because the ExchangePrincipal object contains outdated information. The mailbox may have been moved recently."
  }
}

 

 

 

flow error.PNG

 

 

7 REPLIES 7
ScottShearer
Super User III
Super User III

@ullurr:

 

Can you post a screen shot of your Flow?  That will make it much easier to assist.

 

Scott

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
v-yuazh-msft
Community Support
Community Support

Hi @ullurr,

 

The error message of your flow told the specified object was not found so the flow run failed, Please check if the arrived email would be deleted or moved so the email couldn't be found when the "Export Email" action runs.

 

I have made a test on my side and don't have the issue that you mentioned.

 

The screenshot of my flow as below:

Capture.PNG

 

The flow would run successfully as below:

Capture.PNG

 

Best regards,

Alice

Hi Alice,

 

Thank you for the Help,

 

I tried wtih different SharedMail Box i get same error when flow is Run. Mail box is live and i have full access still same error. 

 

Error Flow

flow error 1.PNG

@ScottShearer

Thank you for the help

Attached is the screen Shot of the flow and error

flow error 1.PNG

Hi @ullurr

 

Have your problem still exists?

 

 

Best regards,

Alice

Hi @v-yuazh-msft

 

Yes we Still have this issue not able to find a solution for both Inbox and Sub-Folders. 

 

Regards,

 

Ullur

FrederickDhooge
Frequent Visitor

I have the same issue. This morning it worked fine, then I changed something in my flow and it doesn't work anymore.

I already exported en imported the flow again, but it wasn't resolved.

2019-06-05 21_40_07-Window.png

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (54,214)