cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Vibindas
Level: Powered On

Send email action fails from 21 January - Getting unauthorized error in some runs

Getting Unauthorized error in email send action for last few days. Was working fine before. If failed runs is rerun manually, it succeeds.

Only some runs are failing. Any idea?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Send email action fails from 21 January - Getting unauthorized error in some runs

Hi @Vibindas ,

 

Please take a try to delete the connection to outlook and create a new connection to see if the issue still exists.

I'm afraid that the token in the connection is expired.

 

Best regards,

Alice       

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
Community Support Team
Community Support Team

Re: Send email action fails from 21 January - Getting unauthorized error in some runs

Hi @Vibindas ,

 

Please take a try to delete the connection to outlook and create a new connection to see if the issue still exists.

I'm afraid that the token in the connection is expired.

 

Best regards,

Alice       

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Vibindas
Level: Powered On

Re: Send email action fails from 21 January - Getting unauthorized error in some runs

hi, it was sending emails regularly. what is the condition for token expiry?

Highlighted
Super User
Super User

Re: Send email action fails from 21 January - Getting unauthorized error in some runs

Go to your Connections within Power Automate settings under Data > Connections

Connections.png

Then, Edit or Delete and Re-Add the account email account. You'll want to see "Connected" once you've re-added the account.

Verify.png

👨🏻‍💻 If this reply answers your question or solves your issue, please ACCEPT AS SOLUTION ☑️. If you find this reply helpful, please consider giving it a LIKE 👍.

Vibindas
Level: Powered On

Re: Send email action fails from 21 January - Getting unauthorized error in some runs

Hi , i have created a new flow with new connections(deleted existing connections). Still it is failing intermittently.

As you can see in below screenshot, content-length is 279 for all failed runs and 0 for successful runs. also x-ms-apihub-cached-response is true for failed runs. Please advise.

 

failure.pngsuccess.png

Super User
Super User

Re: Send email action fails from 21 January - Getting unauthorized error in some runs

Unfortunately, we can't help you further on the forums as we are community volunteers with no access to account information or the system backend. Please contact Power Automate support directly so they can review your account related issues - https://flow.microsoft.com/en-us/support/

ContactSupport.png

👨🏻‍💻 If this reply answers your question or solves your issue, please ACCEPT AS SOLUTION ☑️. If you find this reply helpful, please consider giving it a LIKE 👍.

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons in April

Read the announcement for more information!

firstImage

Better Together Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Kudoed Authors
Users online (2,673)