cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Send mail (v2) when new entry in sql table is created only works in test mode

Hey Guys, 

 

I'm taking my first steps with power automate. 

What I want to do is to send a mail when a new entry in a sql table (dynamics nav on prem) is created. 

 

I created the connection to the sql database like this: 


flow.jpg

 

But the flow doesn't work. 
When I go to edit -> test -> with data from sql -> the flow works and I get the mail 

 

What is the problem? 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Send mail (v2) when new entry in sql table is created only works in test mode

 

Hi @powertube ,

 

First, make sure the trigger you use is When an item is created (V2) and not When an item is modified (V2).

 

In addition, Flow may be triggered later. When you test, you can wait for a few minutes and see if Flow is executed normally.

 

If the connection is created for the first time, there may be a delay.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Highlighted
Super User
Super User

Re: Send mail (v2) when new entry in sql table is created only works in test mode

Hi @powertube 

 

Your flow steps looks good to me. Could you try deleting the trigger step and recreate again.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Highlighted
Community Support
Community Support

Re: Send mail (v2) when new entry in sql table is created only works in test mode

 

Hi @powertube ,

 

First, make sure the trigger you use is When an item is created (V2) and not When an item is modified (V2).

 

In addition, Flow may be triggered later. When you test, you can wait for a few minutes and see if Flow is executed normally.

 

If the connection is created for the first time, there may be a delay.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (7,785)