cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
petewalburn
Helper II
Helper II

Sending email with Send an HTTP request to SharePoint

Hi,

 

I am using Send and HTTP request to SharePoint to send an email from my Power Automate flow.  The email is sent to the user in the 'CC' line, but the 'TO' line is blank in Outlook.

 

This is a picture of what I have:

petewalburn_2-1666097130660.png

 

Any ideas as to why it does not send to the TO: users?  

 

Pete

 

5 REPLIES 5
petewalburn
Helper II
Helper II

The generated JSON is:

{
'properties':
{"__metadata":{"type":"SP.Utilities.EmailProperties"},
'To':{"results":['valid email address','another valid email address']},
'CC':{"results":['and another valid email address']},
'Subject': 'FNC

Kaif_Siddique
Solution Sage
Solution Sage

Hi @petewalburn ,

 

Could you add a Step before Sent an HTTP request and check Approver Email and Approver Back.. have values or not.

 

Regards

Kaif

Kaif

 

I have added a condition to check for the Approver Email and Approver Backup Email being blank. If they are, I set them again.

It is now sending the email to the Backup Approver Email, but not the Approver Email. However, I include the Approver Email (and Backup Approver Email) text within the email text to check that they do have values (and they do).

 

Pete

Hello Pete,

 

Were you able to resolve this issue, I have a similar issue that I am trying to figure out.

 

Leo 

Leo

 

I have ended up using the Send an email (V2) action, and have a shared mailbox which I add to the From (Send as) entry.  This does seem to work, although there have been users who have not received the emails.  I still have work to do on this to ensure that the emails are always sent when required.

 

Pete

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (5,863)