cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SlavaS1
Helper I
Helper I

Shared Mail box trigger error

Hello dears,

 

I was able to use Message received connector for personal mail box, however I am getting error using trigger for shared mail box.

I have read posts to the same subject but it did not help

https://powerusers.microsoft.com/t5/General-Power-Automate/quot-when-a-new-email-arrives-in-a-shared...

 

I have created the shared mail box more than 2 hours ago, I am a member of the share mail box and I am the flow creator, I created a new connection as well.

 

SlavaS1_0-1607775530321.png

 

SlavaS1_1-1607775597832.png

 

 

I will appreciate for your help

 

Slava

1 ACCEPTED SOLUTION

Accepted Solutions

Hmm, really strange thing. Could you create a new shared mailbox, assign yourself a full access right and test? 

--------------------------------------------------------------------------------------
Contact me if you are interested in custom Power Automate development.

View solution in original post

10 REPLIES 10
Pstork1
Dual Super User
Dual Super User

Based on the error message I would double check the email address for the shared mailbox and also make sure you have access to the mailbox.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Hello @Pstork1  thank you for your reply.

I am global tenant admin, I was able to select the shared mail box from drop down list. I removed semicolon as it was recommended on previous post.

I  have access to the shared mail box via Outlook desktop and I see messages.

SlavaS1_0-1607787040635.png

 

SlavaS1_1-1607787167320.png

 

It looks like the emails in the shared mailbox are from the same shared mailbox.  That could be the problem.  I think the trigger only works for email sent from a different address.  Email sent to itself won't go through the systems required to activate the trigger.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Hi @Pstork1 , I doublechecked and found that all incoming messages are from external addresses, the shared mail box's sent folder is empty at all.

 

I am able to select trigger's Folder when the shared mail box is empty, however once I enter my shared mail box I get error and the flow doesn't work.

SlavaS1_1-1607928632575.png

 

SlavaS1_2-1607928750395.png

 

I have full access to the shared mail box

SlavaS1_3-1607928799269.png

 

 

 

VictorIvanidze
Community Champion
Community Champion

Hi @SlavaS1, do you see the shared mailbox in your Outlook?

Also, what connection you are using in the trigger? Your personal one?

--------------------------------------------------------------------------------------
Contact me if you are interested in custom Power Automate development.

Hi @VictorIvanidze , yes I see the shared mailbox on Outlook

SlavaS1_0-1607941673269.png

 

I use Office 365 Outlook connector created by me as the flow and the mailbox owner. I have recreated the connector some times but it did not help.

SlavaS1_1-1607941928690.png

 

Hmm, really strange thing. Could you create a new shared mailbox, assign yourself a full access right and test? 

--------------------------------------------------------------------------------------
Contact me if you are interested in custom Power Automate development.

Any chance there is a mailbox rule setup in Outlook somewhere that is processing the messages sent to the shared mailbox and moving them?  The error is that it isn't finding the message when it tries to export it.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Hello dears @Pstork1 , @VictorIvanidze ,

As soon as I have created a new shared mailbox, both started working without any additional modifications.

I have developed dozens flows and it's really strange. 

 

Any way thanks a lot for your help.

 

Best regards,

Slava

VictorIvanidze
Community Champion
Community Champion

Wow, great! Glad to know you've got manage it to work.

Don't you think that any IT technology contains a  tiny mystical ingredient? 🙂

--------------------------------------------------------------------------------------
Contact me if you are interested in custom Power Automate development.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

May UG Leader Call Carousel 768x460.png

June User Group Leader Call

Join us on June 28 for our monthly User Group leader call!

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Users online (3,437)