cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Seuadr
Advocate II
Advocate II

Sharepoint - Create item invalid character error, previously worked fine?

Hello,

 

I am running into an issue with the sharepoint create new item function in power automate.

 

I have a flow that reads an excel table, parses it, and then creates an item in sharepoint list. This has been running fine for about a year, but in the last few days i've been getting an error with it saying that there are invalid characters.

 

here is what the flow looks like:

Seuadr_0-1618319221998.png

Seuadr_1-1618319240425.png

Seuadr_2-1618319270533.png

here is a create item raw input from a create item that worked fine:

here is the compose of the inputs for the get item function:
Temporary shutdown of Distribution Panel LDP-A (480/277
volt)  March 25 From 5 a.m. to 7 a.m. on Thursday,  Bioengineering

here is the raw input to the get item function:

"body": {
        "Title": "Temporary shutdown of Distribution Panel LDP-A (480/277\nvolt)  March 25 From 5 a.m. to 7 a.m. on Thursday,  Bioengineering",
        "What": "Temporary shutdown of Distribution Panel LDP-A (480/277\nvolt)",
        "When": " March 25 From 5 a.m. to 7 a.m. on Thursday, ",
        "Where": "Bioengineering"
    }

here is a create item raw input that contains invalid characters:

here is the componse that makes up the raw inputs:

Infrastructure Planning and Facilities High Voltage Crew will be disconnecting the temporary
construction transformer and electrical service that was used to power the site
while under construction.  April 13 From 5 a.m. to 6:30 a.m.,  Central Services and STEM Temporary Construction Transformer    

here is the raw input to the get item function:
"body": {
        "Title": "Infrastructure Planning and Facilities High Voltage Crew will be disconnecting the temporary\nconstruction transformer and electrical service that was used to power the site\nwhile under construction.  April 13 From 5 a.m. to 6:30 a.m.,  Central Services and STEM Temporary Construction Transformer",
        "What": "Infrastructure Planning and Facilities High Voltage Crew will be disconnecting the temporary\nconstruction transformer and electrical service that was used to power the site\nwhile under construction.",
        "When": " April 13 From 5 a.m. to 6:30 a.m., ",
        "Where": "Central Services and STEM Temporary Construction Transformer"
    }

at first i thought it might be the /n characters, but, then i noticed that they are in both. i don't see any other obvious invalid characters, but, i admit that i may not recognize many of them.

 

any input into what the characters might be or how to better troubleshoot this would be greatly appreciated.

 

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Seuadr
Advocate II
Advocate II

So, my original question got snagged by the spam filter, so i created a new one that was the same issue but structured differently in the hopes that it wouldn't also get caught by the spam filter.

Someone replied to that thread with the solution:
Link! 

 

the problem was exceeding the 255 character limit. it didn't even occur to me that it might be hitting a character limit, i didn't realize that the title field of sharepoint lists is a single line. 

thanks @annajhaveri !

View solution in original post

4 REPLIES 4
Mira_Ghaly
Dual Super User II
Dual Super User II

@Seuadr 

I can't get what might be invalid but for troubleshooting this .. I suggest that on the Create Item to pass one field at a time and test , till you narrow down the issue to which field and then we can take it from there

So Set Title and Run 

Then Set Title and What and Run

and so On 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

@Mira_Ghaly thanks for the input - i'll give that a go. I apologize for the slow response, i will follow up once i've had a chance to explore the individual parts.

so it looks like the offending character is in the compose action that ties all of the individual items together.

{
  "Title": "Infrastructure Planning and Facilities High Voltage Crew will be disconnecting the temporary construction transformer and electrical service that was used to power the site while under construction.  April 14 From 5 a.m. to 6:30 a.m.,  Central Services and STEM Temporary Construction Transformer",
  "What": "Infrastructure Planning and Facilities High Voltage Crew will be disconnecting the temporary construction transformer and electrical service that was used to power the site while under construction.",
  "When": " April 14 From 5 a.m. to 6:30 a.m., ",
  "Where": "Central Services and STEM Temporary Construction Transformer"
}

i ran the create item with just the individual items that make up the title: What, Where, When and they all run fine when they are seperated. 

the compose action just takes them and puts them together - i'm not sure why it would cause an "invalid character"

so i tried putting the outputs straight into the title instead of using the compose - still fails... but each one separately works fine?!

so next i tried pairs - what and when work fine, when and where work fine, where and what fail. what and where also fail. putting when in the middle and swapping what and where makes no difference. there is something about the combination of characters that what and where provide that causes the failure - but if the order doesn't matter, that suggests that it isn't an issue with two characters combining to accidentally create an invalid character, so i am a bit baffled. 

 

 

 

Seuadr
Advocate II
Advocate II

So, my original question got snagged by the spam filter, so i created a new one that was the same issue but structured differently in the hopes that it wouldn't also get caught by the spam filter.

Someone replied to that thread with the solution:
Link! 

 

the problem was exceeding the 255 character limit. it didn't even occur to me that it might be hitting a character limit, i didn't realize that the title field of sharepoint lists is a single line. 

thanks @annajhaveri !

View solution in original post

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (66,516)