cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Sharepoint Site missing from flow

I have a group of Sharepoint sites that do not show up in flow when I have tried to do a number of flows involving them.  About half of the sharepoint sites exist in the dropdown list.

 

I am attempting to create some simple flows such as saving email attachments and syncing 2 sharepoint folders.  

 

I have attempted to use 'add custom value' and paste the link to the site in but that fails in validation when saving the flow.

 

I cannot find other solutions to this so far in the community.

 

Is there a setting somewhere that is affecting this?  These are templated flows and are quite simple.  Any help appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

A consultant I hired was able to solve very quickly.

 

There was a special character ' in my URL.

 

He recommended either create a new site or encode the ' with %27.  Working fine now.

View solution in original post

21 REPLIES 21
Highlighted
Community Support
Community Support

Hi @jsia,

 

Could you please share some examples for the site Address that not working with the Flow action?

It would work if you enter the proper Site Address.

The format for the custom value about the Site Address should be as below:

https://OrgName.sharepoint.com/SubsiteName

See image reference:

24.PNG

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

A consultant I hired was able to solve very quickly.

 

There was a special character ' in my URL.

 

He recommended either create a new site or encode the ' with %27.  Working fine now.

View solution in original post

Regular Visitor

THis is not working in all respects. I need help!  I cannot contnue further and thinking of abandoning SharePoint completely. I have created different sites but stil the site address is not coming up,

Highlighted
Regular Visitor

Can you please please help. I cannot find any solution apart from perhaps dropping SharePoint entirely.

Highlighted
Regular Visitor

Even new site does not work. Microsoft is so quiet on this.  Very very very bad and sad

Highlighted

I found help by going to Upwork.com and finding a consultant that could help me easily.  Only took him an hour to figure it out.

Highlighted
Regular Visitor

Thank you. Let me try.

Highlighted
New Member

I'm having the same issue of my site not being selectable from the drop down. It is in my coworkers flow as an option but not mine so it's not anything with special characters. Any suggestions?

Highlighted

Typing in the SharePoint site address manually was the only other solution I've heard of.  Mine happened to have the special characters issue.

Highlighted

That does not work, I've tried.

Highlighted
Advocate II
Advocate II

No matter how i type in the URL (Not copy and pasting either),  https://<company name>.sharepoint.com/depts/IT or https://<company name>.sharepoint.com/depts/IT/, flow cant find it within itself to actually work. i can type that address in a browser and it finds it just fine. Ive tried this on IE, Chrome, Edge with no luck. Flow is so buggy its rediculous, i mean, how hard is it to find a site if you provide the URL? Cmon MS, yall gotta do something about this, SPD would ALWAYS find my site

Highlighted
Anonymous
Not applicable

Have you tried removing the 'https://'? I had this issue just now and removed that and it worked

Highlighted
Anonymous
Not applicable

I dont have any special characters in my site URL, but still it doesnt work.  Did you get any further clarification?

Highlighted

Not other than whats been shared here.

Highlighted
Anonymous
Not applicable

Okay thanks for the information.  I will log a support request.

Highlighted

Hi, 

 

Have you had any fruitful feedback from MS on this topic? I've tried all the above tricks without any success. 

 

Thanks, 

Linda

Highlighted
New Member

I see this thread hasn't been commented on for a few months, but I was having a similar issue while trying to connect to my Sharepoint Site from within the 'New Flow' interface and my search for a solution led me straight here, so I thought I would share my discovery.

 

When typing or copy/pasting my URL into the 'Site Address' box, the URL would auto trim down to the correct Site URL as if it were connecting, but the site would not appear in the dropdown.  What I figured out was that it was, in fact, correctly connecting to the Site.  The dropdown itself was the issue: it wasn't displaying anything useful, and was covering up the 'List Name' box.  I discovered that when I clicked next to the URL in the 'Site Address' box, as if to type more characters, and pressed Enter, the cursor dropped down to a new line.  I did this 3 times, and saw the 'List Name' box emerge underneath the dropdown.  I then clicked into the 'List Name' box, and there were all the Sharepoint Lists!  Once a list was selected, everything performed as normal, and I was able to click back into the 'Site Address' box to remove the line breaks I had put in (I don't know if they need to be removed, but my OCD would not permit them to stay).

 

Hope this helps some people out!

Highlighted
New Member

I found that the field to enter a site URL is a multi line field. So all my previous attempts were on other lines hidden below the current line. make sure you clear out ALL the characters from all lines of the site address field.

 

This worked for me.

Highlighted
Helper I
Helper I

Hello all,

it is happening to me now.   In first picture, I was trying to modify an existing flow. First step was part of an old flow, it can still see my sharepoints and I can select them.

But as you can see, in the newly added second step, Get File content 2, it does not see the sharepoints anymore.

Capture.PNG

 

Same for creating a brand new flow, no sharepoints available:

Capture2.PNG

 

Any advice? Can it be related to the browser? I just switched from one browser to another ( unistalled the previous one but logged in in everything needed in the new one). Thanks

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (12,076)