cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

The "Get Element" ID isn't the same as the "Form response" ID.

Hi. 

I hope that you guys can help me!

I have this problem that the element id isn't the same as the form response ID. 
So the result is to differents outputs. 

My form looks like this: 

lundte_0-1594289213181.png


But the outcome is this:

Formular response id 29

lundte_1-1594289294898.png

Sharepoint ID 29

lundte_2-1594289348270.png

 

What do I do wrong?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Dual Super User III
Dual Super User III

Re: The "Get Element" ID isn't the same as the "Form response" ID.

Hi!

Weare closer to a happy ending, just forgot the spaces, one between internal column name and operator, the second one between the operator and the first single quote:

ContractNumber_x003a_ eq '527497 '

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



View solution in original post

9 REPLIES 9
Highlighted
Dual Super User III
Dual Super User III

Re: The "Get Element" ID isn't the same as the "Form response" ID.

Hi!

Where does the 'Formular response id 29' come from?

Is there a specific question on your Form asking for the responder to enter this ID?

Thanx!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Highlighted
New Member

Re: The "Get Element" ID isn't the same as the "Form response" ID.

Hi. 

I think ID comes from the number of responses. I actually dont know, it isnt a number I give it. 
The only unik number in the form, is the Contract number. 

 

Regards
Daniel

Highlighted
Dual Super User III
Dual Super User III

Re: The "Get Element" ID isn't the same as the "Form response" ID.

Hi!

Is the contract number unique in your SP list? I mean, do you have no more than one element in your SP list with a specific Contract Number?

If so, you can replace 'Get item' and use 'Get items' instead. In order to read your target element, you can assign an ODATA  in 'Filter query' input, or add a 'Filter array' action block after your 'Get items'

Flow_GetItems_UniqueID.png

Please take a try and let us know your progress

Thanx!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Highlighted
New Member

Re: The "Get Element" ID isn't the same as the "Form response" ID.

When I try your solution is says that the "request is invalid".

lundte_0-1594294989696.png

 

Regards
Daniel

 

Highlighted
Dual Super User III
Dual Super User III

Re: The "Get Element" ID isn't the same as the "Form response" ID.

Hi!

According to your screenshot you are not building the ODATA Filter correctly, please check again the screenshot I shared as example

The internal column name is missing, the operator also, and you forgot to add the single quotes

Please try again and let us know your progress

Thanx!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Highlighted
New Member

Re: The "Get Element" ID isn't the same as the "Form response" ID.

Hi. 

Still a issue 😕 

lundte_0-1594299083711.png

"message""The term \"ContractNumber_x003a_eq'527497 '\" is invalid.

Regards
Daniel
Highlighted
Dual Super User III
Dual Super User III

Re: The "Get Element" ID isn't the same as the "Form response" ID.

Hi!

Weare closer to a happy ending, just forgot the spaces, one between internal column name and operator, the second one between the operator and the first single quote:

ContractNumber_x003a_ eq '527497 '

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



View solution in original post

Highlighted
New Member

Re: The "Get Element" ID isn't the same as the "Form response" ID.

Oh Jesus....

Sry for being an rookie and thx a lot for your help and time! 

It works now!! 

Highlighted
Dual Super User III
Dual Super User III

Re: The "Get Element" ID isn't the same as the "Form response" ID.

No problema, I also had such mistake when started working with Power Automate 😄

Happy Flowing!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (8,074)