cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kakis
New Member

The request failed. Error code: '502'. Error Message: 'BadGateway'. On Start and wait for Approval.

Hi everyone,

We have recently(2 months) started using D365 CE and all of our flows have been working perfectly since then.
Two days ago we installed Dynamics Marketing and we are now getting a Bad Gateway error on our start and wait for approval flows since then?
I don't really get how installing Marketing broke the approvals?


I have tried the following without any success:
Rebuilt the flow
Saved it as something else

Created a brand new simple approval flow with a manual trigger

Please note Approvals are working fine in all other environments. Is there anything i am missing?
Any Kind of help is appreciated!

 

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions

Hi, thanks for the reply! 
it was none of the above! Microsoft support reached out to me and helped!

 

the solution was adding the read permission on the Approvals Administrator role for the System Job in the customizations tab. After doing that we no longer get the bad gateway error on approvals! 🤷🏻‍♂️ 

View solution in original post

6 REPLIES 6
Johnnyg
Community Support
Community Support

Have you finished new Marketing environment dataverse database provision as below official doc mentioned?
Please share more issue details if you have set up environment db and you already found approval entity under your environment entity table.

https://docs.microsoft.com/en-us/power-automate/get-started-approvals#permissions-to-create-a-datave... 
https://support.microsoft.com/en-us/topic/power-automate-approvals-provisioning-overview-and-trouble... 

Johnnyg_0-1622984487535.png

 

 

Best Regards,
Johnny
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi, thanks for the reply! 
it was none of the above! Microsoft support reached out to me and helped!

 

the solution was adding the read permission on the Approvals Administrator role for the System Job in the customizations tab. After doing that we no longer get the bad gateway error on approvals! 🤷🏻‍♂️ 

IngoKlug
Regular Visitor

Is there any Link to a description / video how to do that?
I am lost in Power Platform Admin Center - found the Approval Administrator, but where do I find the System Job or the customization tab? (Please excuse grammar or other mistakes - I am German). 
502 - Bad Gateway / Power Automate Approval does not work.

MarceloSarmento
New Member

This really did the trick for me. Worked right away.

 

@IngoKlug  here is some documentation on how to do it:

Configure user security in an environment - Power Platform | Microsoft Docs

 

MarceloSarmento_1-1631152248621.png

 

THX - that‘s it!

kestenholz
Frequent Visitor

Solved it for me to!

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (4,884)