cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
aakashdmorya
Advocate II
Advocate II

The response is not in a JSON format - Working with SharePoint List and Flow

I am having a list which has 4800 items. I am iterating a flow on each item to process. While flow is in running mode, it always fails for a random ID with the reason "The response is not in a JSON format.".

 

Initially I thought of some data problem, but when I ran flow multiple times then I realized that the same error is occurring for different id in different runs. For example,

 

  1. For ID 3962, flow ran successfully.
  2. For second run, for ID 3962 thrown error
  3. For third run, same error occurred for ID 4528 and for ID 3962, the flow ran successfully.

So any one have idea what may causing an issue? Please find below snapshot.

 

Capture.PNG

 

Actual Error message:

 

 

{
  "error": {
    "code": 502,
    "source": "unitedstates-002.azure-apim.net",
    "clientRequestId": "9c1eb846-a4fd-4891-946d-0a2bac080285",
    "message": "The response is not in a JSON format.",
    "innerError": "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01//EN\"\"http://www.w3.org/TR/html4/strict.dtd\">\r\n<HTML><HEAD><TITLE>Service Unavailable</TITLE>\r\n<META HTTP-EQUIV=\"Content-Type\" Content=\"text/html; charset=us-ascii\"></HEAD>\r\n<BODY><h2>Service Unavailable</h2>\r\n<hr><p>HTTP Error 503. The service is unavailable.</p>\r\n</BODY></HTML>\r\n"
  }
}

 

 

Any help or suggestion is most welcome

2 REPLIES 2
v-litu-msft
Community Support
Community Support

Hi @aakashdmorya,

 

The error code 500 or 502 appears means the failure is temporary or transient. It’s possible the server is overloaded or there are network issues between the two servers. It’s also possible there’s an improperly configured firewall or even a coding error.

Please click or tap Resubmit to try the flow again and let me know if the issue still exists.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Ullrskier
New Member

For me this was a permissions issue.  The Logic App connected user has to have permissions on the site you are accessing.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,494)