cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Trying to pull DisplayName from Person or Group from a Sharepoint list

Hi everyone,


I have a Flow that runs when an item is modified in a SP list. The original list has two Person or Group fields, one for Manager and one for Director.

 

The flow sends an email and both in the To: and Body: fields, I need to be able to put the Manager and Director fields. 

When I try to do this, I get multiple options, such as Director DisplayName (for the body message).


When I choose this, the action automatically transforms into an Apply to Each action. Can I prevent this? Because if I run the flow like this, while it actually pulls the name correctly, it continues doing it for each item on the list and of course I get 30+ emails in my inbox if I don't stop the flow.

 

What am I doing wrong? Please help.

 

 

4 REPLIES 4
Community Support
Community Support

Hi @Anonymous,

 

Are you trying to send an email to both the Manager and Director? Could you show me a screenshot of your flow?

 

I created a simple flow to test this issue. There are two Person and Group fields in the list named as Manager and Director. In the To field of the action Send an email, select dynamic contents Manager Email and Director Email. I didn’t get an Apply to each action on my side.

1.PNG

 

Please feel free reply if you need more help.

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Yikes, I wonder if it's how my organization is setup?

I have tried both Chrome and Edge and the same thing happens. I used to get a notification saying why it was automatically created, but I dismissed it and I don't know how to make the message show up again.

 

Here's what it looks like before and after.

 

Here I try to place "Director DisplayName" where the cursor is:

 

 

 

 

Immediately after selecting it, this happens:

 

 

 

As you can see, it puts the "Send an email" inside the "Apply to each" step. And if I keep adding other fields such as Manager DisplayName, it keeps creating additional "Apply to each" steps within each other as so:

 

 

Interestingly, once I've added one, any other fields related to it, no longer create instances. For example, if I put "Manager DisplayName", it creates the Appy to each step. If I continue to add "Manager email" or "Manager Department", it no longer adds an Apply to each step.

 

Thank you for your assistance so far.

Anonymous
Not applicable

I created a new flow, and it has the same behavior, but this time I got the pop-up notification to show up:

 

Flow4.png

Anonymous
Not applicable

I created a NEW list and it actually works there. So it's definitely related to how the list is built I guess. 

If you need more information please let me know.

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Microsoft Ignite

Microsoft Power Platform: 2021 Release Wave 1 Plan

Power Platform release plan for the 2021 release wave 1 describes all new features releasing from April through September 2021.

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (16,129)