cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Alex_Adkin
Helper II
Helper II

Unable to process template language expressions for action

Can anyone help with this error, the issue is below

 

The template language function 'lessOrEquals' expects all of its parameters to be either integer or decimal numbers. Found invalid parameter types: Null

 

The condition above works fine with a single value of 7 but I need to ascertain a figure between 5 -7 as below am I constructing the logic incorrectly?

 

Thanks 

 

greateless.PNG

1 ACCEPTED SOLUTION

Accepted Solutions

Thanks Barry, 

 

This helped after much trial and error the flow runs with success, for some reason i had to set it to run as a condition branch with the composed dynamic values. 

 

Thanks for the guidance, ive learnt alot. 

View solution in original post

8 REPLIES 8
v-bacao-msft
Community Support
Community Support

 

Hi @Alex_Adkin ,

 

It is mentioned in the Error message that the current value of this field is empty, so it cannot be compared.

 

Please make sure that the field value is not empty so that the conditions set in Condition will be valid.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

The field has data though. This field is default to 0 until a rollup occurs so there is data 

 

Hi @Alex_Adkin ,

 

But the error message reflects that this field is indeed empty. You can try to add a Compose above the Condition to output the Dynamic content you configured in the Condition. Run Flow and check whether the value of this field is empty.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Alex_Adkin_0-1602491763310.png

 

 

HI the compose shows me an expected value, thanks

 

Hi @Alex_Adkin ,

 

I think you seem to need to configure the Compose configuration in Apply to each to see if the value of the dynamic content in your current configuration Condition is empty.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Barry, 

 

have applied a compose and im getting data. is this what you meant?

 

Alex_Adkin_0-1602669849531.png

 

 

Hi @Alex_Adkin ,

 

Now that you have filled the dynamic content you need to configure in the Condition in the Compose, you can directly configure the output of the Compose in the Condition to ensure that the value is not empty.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks Barry, 

 

This helped after much trial and error the flow runs with success, for some reason i had to set it to run as a condition branch with the composed dynamic values. 

 

Thanks for the guidance, ive learnt alot. 

View solution in original post

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (37,964)