cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PaoloBM
Helper I
Helper I

Update SharePoint list daily with HTTP request going wrong.

Hi, I'm getting an error after configuring my PA flow.

 

The flow is below, I'm trying to update the "Created" and "Client Birthday" so the 2 calculated columns based on these values can be updated daily ("Waiting time(calc)" & "Client Age(calc)").

The formula for "Waiting time(calc)" is =DATEDIF(Created,TODAY(),"d").

The formula for "Client Age(calc)" is =DATEDIF([Client Birthday],TODAY(),"Y").

The idea is, for each item send an http request updating the fields with the same value, just to trigger the update to all items/columns.

 

upper partupper partbottom partbottom part

 

The result is below, and I don't understand the error details, since it should be a simple update task lol.

errorerror

 

What are your suggestions to fix this or take another approach to this problem?

Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
v-chengfen-msft
Microsoft
Microsoft

Hi @PaoloBM ,

The reason why you met this problem is that:
1.Body's content format error

 

vchengfenmsft_0-1663749780780.png

 

 

Here is format

vchengfenmsft_2-1663750418508.png

 

 

 

 

Best Regards

Cheng Feng

View solution in original post

4 REPLIES 4
v-chengfen-msft
Microsoft
Microsoft

Hi @PaoloBM ,

The reason why you met this problem is that:
1.Body's content format error

 

vchengfenmsft_0-1663749780780.png

 

 

Here is format

vchengfenmsft_2-1663750418508.png

 

 

 

 

Best Regards

Cheng Feng

PaoloBM
Helper I
Helper I

Thank you for the reply.

I've overcome this by removing the calculated formulas on the list and now I calculate them via Power Automate daily using the "SharePoint update item".

PaoloBM
Helper I
Helper I

Hi again @v-chengfen-msft, now I'm having the same issue with another HTTP request, could you please help?

 

It's a Yes/No choice

PaoloBM_0-1665692798518.png

 

The field name in the URL shows: &Field=RiskLevel (I must have renamed it to add the space later.)

 

That's the flow:

PaoloBM_1-1665692966492.png

 

{"odata.error":{"code":"-1, Microsoft.SharePoint.Client.ClientServiceException","message":{"lang":"en-US","value":"The request ETag value '' does not match the object's ETag value '\"79a52562-d0ad-4e21--bdfba772f99d,45\"'."}}}
clientRequestId: e650c21c-cfa7-4661--c246f4c5fa7b
serviceRequestId: 30536ea0-d06b-2000--cb25cf085f4d

 

I've tried with the values: Yes, "Yes", No, "No, "true", true, "false", false.

They all give me the same error.

 

Suggestions are appreciated.

Thank you.

Solved the issue, the list name was first called something else and then renamed.

When calling the metadata, it couldn't find the model with the new name, only with the old name.

{
"__metadata": { "type": "SP.Data.<FirstEverName>ListItem"},
"RiskLevel": false
}

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (3,615)