cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
HaiNguyen202
Helper I
Helper I

[Urgent case!!!!!!] How to use Filter Query for List rows present in a table.

Hi,

I would like to ask about my flow within using Filter query. You can see if I don't apply any filter the value box would contain 3 values. However, when I apply the filter query the value is unavailable. Please find the pictures attached.

 

this pic indicates there are 3 values if I don't apply any filter query.

HaiNguyen202_1-1635918732558.png

 

this pic indicates there is no any value when I apply the filter, but it should be 1 because there is a value having the same value in the table (please check the Excel table on the last pic). 

HaiNguyen202_2-1635918826671.png

Basically, I would like to apply a condition that if the number of value within filter query applied is 1 then do next step, and think that when I apply the filter query the value should be 1, but the value is 0. 

HaiNguyen202_3-1635918952126.png

length(outputs('List_rows_present_in_a_table_2')?['body/value'])

 

Here is my table. 

HaiNguyen202_4-1635919048623.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

@v-xiaochen-msft Thank you for your support!.

HaiNguyen202_0-1636109851849.png

HaiNguyen202_1-1636110240003.png

 

 

However, it's still not working either with quote mark nor without it. The value is still empty! And I have changed the column name. The value in the column must be number so I cannot change it. I think it's a bug so could you please report it. 

 

View solution in original post

13 REPLIES 13
Mira_Ghaly
Dual Super User
Dual Super User

@HaiNguyen202 

Try removing the single quotes

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here
HaiNguyen202
Helper I
Helper I

Hi @Mira_Ghaly,

 

Thanks for your response. I have tried and didn't work. btw, do you know which the format in excel table is appropriate to the filter query?

HaiNguyen202
Helper I
Helper I

 

the value is still empty

HaiNguyen202_1-1635921794468.png

 

 

@HaiNguyen202 

Actually your filter query looks ok.. there is no specific format required, what is the format of your column so I can try to reproduce at my side?

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here
HaiNguyen202
Helper I
Helper I

Hi @Mira_Ghaly ,

I have deleted the format and tried again, and it's still not working. Now my format is General. 

HaiNguyen202_0-1635929261681.png

I have created another table, another excel file, new flow and set the filter query: ID eq 1 and ID eq '1' (the picture below), the value is still empty. BUT when I filter the Name column Name eq 'Hai nguyen', the value is 2 (so it's working). THEN I applied this method to the previous table, filter the Name column but the value is still empty. Please help me out!

HaiNguyen202_1-1635929470905.png

 

@HaiNguyen202 

Can you try with number format?

Is there is any other tables on your excel sheet?

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here
HaiNguyen202
Helper I
Helper I

Hi @Mira_Ghaly ,

I have tried every format for 4 hours. and there is the only table in my sheet (but I think it's not the issue).

@HaiNguyen202 

I have tried on the excel sheet you shared but no matter what I experienced the same behaviour you are experiencing , i could only work using the Filter array as below:

Mira_Ghaly_0-1635934762789.png

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here
HaiNguyen202
Helper I
Helper I

Thanks @Mira_Ghaly 

The reason I want to use filter query as I need to work on the dedicated row. Yesterday, I worked normally on this filter but today the issue starts.  

@HaiNguyen202 

Let me know if this has worked for you!

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Hi @Mira_Ghaly ,

I think MS power automate has been updated something new and this is the bug, as last time I still used it smoothly. Do you know how to call out the MS support team?

v-xiaochen-msft
Community Support
Community Support

Hi @HaiNguyen202 ,

 

Please do not use numbers as column names of excel table.

This causes many problems .

So, please try these steps:

1\ Rename your column name.

2\ Delete the parameters in this option and reselect the same excel file.

vxiaochenmsft_0-1636099518547.png

 

3\ Save the flow.

4\ Clear the browser cache and retest

 

Best Regards,

Wearsky

 

 

@v-xiaochen-msft Thank you for your support!.

HaiNguyen202_0-1636109851849.png

HaiNguyen202_1-1636110240003.png

 

 

However, it's still not working either with quote mark nor without it. The value is still empty! And I have changed the column name. The value in the column must be number so I cannot change it. I think it's a bug so could you please report it. 

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (2,618)