cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
in2217
Resolver I
Resolver I

What takes so long?

Dear community,

 

we had a couple of failures recently, due to timeout. Flow took too long to respond.

Apparently offender is this scope part: it has two Compose steps, each run OK, pretty fast.

But the Scope itself took whole 2 min.

 

Why is that and what can be done about it, besides increasing the timeout?

flow_running_too_long.jpg

 

Thank you,

Inna

1 ACCEPTED SOLUTION

Accepted Solutions
ChristianAbata
Community Champion
Community Champion

hi @in2217  scope is a separated space, like a group so sometimes  the number of seconds are malformed. See your flow runs actually in 7s because the compose inside has 5 and 2 seconds. don't worry about the seconds of scope



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

View solution in original post

2 REPLIES 2
ChristianAbata
Community Champion
Community Champion

hi @in2217  scope is a separated space, like a group so sometimes  the number of seconds are malformed. See your flow runs actually in 7s because the compose inside has 5 and 2 seconds. don't worry about the seconds of scope



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA
beyondthebox
Regular Visitor

Its ok if its a malformed value provided the flow did not actually take 2 minutes to complete the scope. To me this is a  huge issue as you cannot accurately assess issues. I have a flow that sends 14 emails in 5 min. The flow continues to run for 12 min. There are no errors in the flow and the output is 100% what was expected. Once the flow reaches about 12 min it end and then the run execution says it was not 5 min. So I waited 12 min for it to complete even though it was actually done. Hence you cannot just dismiss the timing as malformed if it matches the actual time to run.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (1,910)