cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Bestebreurtje
Helper I
Helper I

When a new email arrives in a shared mailbox - error InvalidTemplate

Flow configuration1.png

I've been testing a very simple but it gives me a error saving the file on SharePoint.

Error Flow.png

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-bacao-msft
Community Support
Community Support

Hi @Bestebreurtje,

 

You could set "Has Attachment" and "Include Attachments" of the trigger to Yes.

If you want to use the attachments included in the email, "Include Attachments" must be set to Yes so that the returned content will contain Attachments.

Image reference:

29.PNG

Please take a try again.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
AlanPs1
Resident Rockstar
Resident Rockstar

Hi there.

Below is a successful Flow run that triggerred when a new email arrived in a shared mailbox.

The flow then got the email's attachment (I added if file is format .pdf in my test) and created a file in a SP document library.

Capture-029.png

 Here is the completed Flow and it's expressions.

 
Capture-031.png

Capture-032.png

Condition Expresssion below:

@contains(items('Apply_to_each_attachment')?['Name'], '.pdf')

Please test this and let us know how you got on.

If this Flow is helpful to you please mark with thumbs up.


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


AlanPs1
Resident Rockstar
Resident Rockstar

On the Final Create File, the file content filed displays "Attachment name".

It should infact display "Attachments Content"as below

items('Apply_to_each_attachment')?['Name']

I find this works better with new email webhook also but try this and see how you get on.

 


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


v-bacao-msft
Community Support
Community Support

Hi @Bestebreurtje,

 

You could set "Has Attachment" and "Include Attachments" of the trigger to Yes.

If you want to use the attachments included in the email, "Include Attachments" must be set to Yes so that the returned content will contain Attachments.

Image reference:

29.PNG

Please take a try again.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi Barry,

 

Thanks,  setting has attachments to "Yes" was resolving my problem!

 

Greetings,

 

Jeroen Bestebreurtje

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (2,154)