cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TheGallons
Helper II
Helper II

add SharePoint list doesn't work....now!! previously it has always worked

Hi everyone, I use a flow to append an excel file to a Sharepoint list, and it has always worked.

Today I try to append some data using the same Flow, which has not been modified, but does not queue anything. No errors are reported and the flow completes successfully.

In the flow I make a comparison on an "ID" field present in the excel file and in the Sharepoint list.

If the IDs are the same, I update the record otherwise I append it.

Based on your experience, what check can I do to understand why no records are queued?

Thanks

8 REPLIES 8
abm
Super User
Super User

Hi @TheGallons 

 

Check the run history of flow. Then expand every single step and look into it.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Thanks Abm. I've another question. I recreated the flow as new. 

On excel file there are 1600 records. After 25 minutes, the flow has added around 1300 records and then, an error is occurred. My question is, can be that the flow does not able to update sharepoint list because the list is opened from application???? 

Hi @TheGallons 

 

What's the error you getting? Also what you meant by list is opened from application?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Hi Abm, 

thanks for the answer.

The error il this: 

TheGallons_1-1653381215629.png

Seems that the error is on "Condition" section but I don't found the reason of the error. 

Is there a way to find it? 

 

 

Hi @TheGallons 

 

Thanks for posting the screenshot. Could you please post that error message in English?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Hi,  

the error on the right page is: 

The 'Condition' action failed

and the description is: 

An action failed. None of the dependent actions have been completed.

 

Thanks Abm

Hi Abm, 

below the complete tranlsation of the error:

Invalid model. Model language expressions cannot be processed in the 'Create_element' action inputs at row '0' and column '0': 'Model language' int 'function was invoked with an invalid parameter. The value cannot be assumed in the target type. '. 

 

Now the excel file I am trying to upload to the sharepoint list has only 2 lines beyond the header.

TheGallons_0-1653810520979.png

 

I don't understand what can be the problem. 

 

Thanks

Davide  

Hi @TheGallons 

 

Thanks for your reply.

 

image.png

 

From your flow run history click the the above link which I highlighted in red above. That will give you which step is failing. Looks like there is an issue with the mapping with some int values?



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (3,344)