cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

approval reject not working

A new Approval Request is sending an email but approve/reject buttons don't actually approve or reject.  When you click on either of them, it redirects the user to the Flow page with the message, "You don’t have any pending requests at this time."

It was working yesterday morning and then stopped working. I thought maybe it was due to some of the changes I had made in other sections of the flow (unrelated to that first step). So today I tried a new flow, "Start approval when a new item is added" and it produces the same behavior when you click on approve or reject button. 

 

The 2nd issue I came accross, if you turn off a flow, it still runs in addition to the new flow I turned on. So I recieve an approval email for both flows and both of them send me to the flow page with e same message listed above.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Anonymous
Not applicable

This issue appears to be resolved. Smiley LOL

View solution in original post

8 REPLIES 8
Highlighted
Anonymous
Not applicable

In further testing, it appears to work fine using online Outlook web but fails with the Outlook client. It possibly could be related to safelinks.protection.outlook.com.

Highlighted
Community Support
Community Support

Hi @ bhogan,

 

Could you please explain more about your issue?

Do you mean you have two issues on the approval flow?

 

The first issue is when click on either of approve or reject, it redirects the user to the Flow page with the message, "You don’t have any pending requests at this time."? 

I have made a test on my side and don't have the issue that you mentioned.

When you click on either of approve or reject on the Outlook client, it redirects the user to the Flow page to make response as screenshot below:

Capture.PNG

 When you click on either of approve or reject on the online Outlook web, you could redirectlly make response to the request.

 

The second issue is  if you turn off a flow, it still runs in addition to the new flow I turned on?

Please make sure you have turned off the flow before the flow runs,if you turn off a flow after the flow runs, the flow would finish  the run of the flow.

 

 

 

Regards,
Alice Zhang

Highlighted
Anonymous
Not applicable

In your screenshot, you are opening the email using the web Outlook.This also works correctly for me.

 

The problem is the majority of our staff uses Microsoft Office Professional Plus 2016 including Outlook.

 

  1. I turned on a default approval flow called, "Start approval when a new item is added" and I turned off my custom flow called, "Change Management Routing -FlowService".Flow turned off.JPG

     

     

  2. I then created a new entry in my list.
  3. I received 4 notifications in Outlook. (This is the second issue which I am not concerned about)Turned off flow.JPG

    Two notifcations are from the flow I turned on.
    Two notifications are from the flow I turned off. 

  4. I open the notification email and if I click on "Approve" or "Reject" it sends me to a flow pageOutlook Client.JPG

    sends me to:

    Flow Page.JPG 

  5. If I open in Outlook web client:Web Client.JPG

    This works as expected. I click approve and the approval process continues.


    The Approve/Reject buttons worked fine Outlook desktop client working fine until the other day. I thought it might be related to safelinks but I had our SharePoint domain whitelisted and this did not resolve the issue.

Highlighted
Anonymous
Not applicable

This issue appears to be resolved. Smiley LOL

View solution in original post

Highlighted

Hi,

 

may I know the solution for your issue with buttons? I have exactly same issue with one of user in our company. He seems to have same Office 365 version as the others, don't know about any exception...

Highlighted
Frequent Visitor

Also having the same issue using Microsoft Outlook Desktop Client 2016 MSO 16.0.4639.1000 32-bit.  Redirects to Approval Center as opposed to allowing users to approve from the e-mail.

Highlighted

Has anyone found a solution to this particular item? 

 

Approve/Reject buttons in approval process works in Outlook web but not in the Outlook desktop client. Has anyone found a solution to get the buttons to work in the desktop client?

Highlighted

Same here as of Monday in my organization.  Simple approval flow.  End user can approve/reject in Outlook web but not Outlook client. 

 

Has anyone found a resolution to this?

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (8,725)