cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
elizi
Advocate I
Advocate I

error while using office 365 connectors inside child flows

I'm trying to use office 365 connectors such as "Send an email (v2)" inside a flow that been called as a child flow from other flow as a part of the solution object and been getting the attached error, what can been done? is anyone encountered this issue and managed to overcome it?

 

the error message:

{
"code": "InvokerConnectionOverrideFailed",
"message": "Failed to parse invoker connections from trigger 'manual' outputs. Exception: Could not find property 'headers.X-MS-APIM-Tokens' in the trigger outputs. Workflow has connection references '[\"shared_office365\"]' with invoker runtime source."
}

 

the flow:

 

2020-02-27_1620.png

 

 

3 REPLIES 3
ChristianAbata
Super User II
Super User II

hi @elizi  please see if thsi solution could help you.

https://powerusers.microsoft.com/t5/Building-Flows/Flow-does-not-work-inside-SharePoint-Online/m-p/4...



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA
mdimillo
Regular Visitor

Did you ever resolve this?  I am having the exact same issue, and am stumped.  The linked solution does not apply to me (I don't think) since I am not triggering the flow from a button in a SP list.  I am trying to create a net new item in a SP list.  My child flow is triggered "manually" from an initial flow.

ldelgado1129
Regular Visitor

I am having the same issue in Power Automate using a Parent and a child Flow:

The Parent Flow is failing: 

Here is the error message:

Failed to parse invoker connections from trigger 'manual' outputs. Exception: Could not find property 'headers.X-MS-APIM-Tokens' in the trigger outputs. Workflow has connection references '["shared_office365users"]' with invoker runtime source.

 

 

In the child flow, I soon as add the 'Get user profile (V2) '    from Office 365 Users action to my child flow, I get the error in the parent flow. The child flow never runs.

 

Has anyone found a solution to this?

I am trying to use the 

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (3,132)