cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

how to config the Modify run-Only users action item in the flow

Hi ,

 

I have created a flow for a selected item and the requirement is this flow should triggered by only Created by user .

How can i achieve this by adding run -only user. Flow is throwing an error if i add  created by email or created by claims as Add user add user id.

 

 

Capture4.PNG

2 REPLIES 2
Community Support
Community Support

Re: how to config the Modify run-Only users action item in the flow

Hi @Anonymous,

 

Could you share more details on your scenario? How is your flow created?

It seems that your flow is triggered by For a selected item. Do you just want to trigger the flow by only the item creator?

Have you tried to get the User Object Id by getting the Id from the Office 365 Users action Get user profile?

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
OvyOne Helper I
Helper I

Re: how to config the Modify run-Only users action item in the flow

Hello Mabel,

 

I'm having a problem when using the Modify Run-Only Users action in my Flow. I can add Run-Only users to other manually triggered flows, however I cannot remove Run-Only users. I am using the same Object User Id when configuring the action for add or remove and User Type is set to User. I am getting the following error when trying to remove an existing Run-Only user from another Flow: 

{
  "error": {
    "code": "AzureResourceManagerRequestFailed",
    "message": "Request to Azure Resource Manager failed with error: '{\"Code\":\"NotFound\",\"Message\":\"Cannot find connection acl with name users.\",\"Target\":null,\"Details\":[{\"Message\":\"Cannot find connection acl with name users.\"},{\"Code\":\"NotFound\"},{\"ErrorEntity\":{\"ExtendedCode\":\"14010\",\"MessageTemplate\":\"Cannot find connection acl with name {0}.\",\"Parameters\":[\"users\"],\"Code\":\"NotFound\",\"Message\":\"Cannot find connection acl with name users.\"}}],\"Innererror\":null}'."
  }
}

Any help would be greatly appreciated.

 

Thanks,

Ovi.

 

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Users online (8,376)