cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AC
Regular Visitor

"ActionBranchingConditionNotSatisfied. The execution of template action 'Send_an_email' skipped:

Hi, Anyone knows how to solve this error "ActionBranchingConditionNotSatisfied. The execution of template action 'Send_an_email' skipped: the branching condition for this action is not satisfied."? I have a Condition. If Yes, then send an email. If No, no action. it is very simple but I can't get past the email part... Your response is much appreciated. Thanks!
10 REPLIES 10
v-monli-msft
Community Support
Community Support

Hi AC,

 

Can you please provide the detailed steps in your flow? I will try to reproduce your issue after you offer more information. Please show the trigger, the detailed info about your condition and actions.

 

Also, try to recreate the flow to test.

 

Regards,

Mona

 

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I'm also getting the same error plus a second error which appears to relate tot he first email having an error..

 

Email 1 error:

ActionBranchingConditionNotSatisfied. The execution of template action 'Send_an_email' skipped: the branching condition for this action is not satisfied.
 
Email 2 error:
ActionConditionFailed. The execution of template action 'Send_an_email_2' is skipped: the 'runAfter' condition for action 'Send_an_email' is not satisfied. Expected status values 'Succeeded' and actual value 'Skipped'.
 
The steps I use are:
'When an Existing Item is modiified' if 'Field A' is equal to 'A' then send emails.
 
 

Hi Mona, 

 

I re-created the flow, result is still the same.

Please find attached screenshot, for your reference.

 

Email Error after a Condition.jpg

 

Regards,

AC

Anonymous
Not applicable

Was a resolution for this ever found - I'm encountering the same?

I also experienced the same problem with the 'Send an email' action.

 

Though I found a solution!

 

I did see something about an error regarding an 'authentication token has expired' before receiving this issue, after I added the 'Send an email' action to the workflow. The error appeared above the action, but has since disappeared. My guess was that the error was still valid, but the display message for the error has disappeared.

 

You can resolve this by:

 

Navigate to your 'Send email' action, and click the '...' > 'My connections' > 'Add new connection'. When I had this error, it was because I had to re-authenticate whatever token is required to sustain the connection. By adding a new connection, it was re-authenticated and emails were successfully sent.

 

Be sure to check the correct email inbox as well, especially if you are using a demo user rather than your regular inbox.

I am also experiencing this error, but with the "Create an event" action for Google Calendar. I tried re-authorizing with no luck. Any other ideas?

Oh wait, I think I was misunderstanding and thought it was an error with the action itself, but I think I messed up my condition (checking category "equals" Blue category, instead of category "contains" Blue category).

Did you ever find a solution to this issue? I am trying to send an email if a condition is equal to Yes as well. It seems to accept the condition but then stalls on that email.

flow email.jpg

 

 

ninjaryder1st
Helper III
Helper III

I am experiencing this as well.   If I allow the "no" condition to be met, the flow terminates even if my condition is met w/ "approve" after completing and approving an approval.     It always terminates out to the right as "successful, canceled, or failed" even though "approve" was selected and it should have proceeded down the "yes" route.   

 

ninjaryder1st_0-1609286684895.png

ninjaryder1st_1-1609286792300.png

 

Placing "true" or "approve" in the flow condition makes no difference in the error occurring and reported as "false" in the test.   Despite having actually approved the approval/condition and noting it should be "true", its not.   

 

why is my input expression recorded as "false" on the control designed to be "true" when the approval notification above is "accepted" via teams notification?    It should state "True" when "accepted" as is not, kicking it to terminate or not complete the next step.  

ninjaryder1st_3-1609287028221.png

 

ninjaryder1st_2-1609287001333.png

 

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (834)