cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
maryleona05
Frequent Visitor

"PreconditionFailed...A record with matching key values already exists. Code: 0x80040237" Flow Approval error

I have a SharePoint flow triggered on new item created that uses the 'Start_and_wait_for_an_approval' action. I've recently been getting a "PreconditionFailed...A record with matching key values already exists. Code: 0x80040237" error at the approval step but I have not made any changes to the workflow. I read a blog from August 2019 on the same issue and it was noted as a widespread issue, but was reported as fixed.   

 

Is this a known recurring issue?

 

Thanks,

Mary

1 ACCEPTED SOLUTION

Accepted Solutions

UPDATE: Issue resolved by recreating the Approvals step in the flows having issues. I followed the advice in a post where a user was having the same issues and the recommeded solution was as follows:

 

"It seems that this seems to be a temporary error, please try to update the connection of the corresponding action or re-create the connection, and then re-submit the Flow."

View solution in original post

5 REPLIES 5
v-alzhan-msft
Community Support
Community Support

Hi @maryleona05 ,

 

Does your issue still exists?

I have made a test on my side and don't have the issue that you mentioned, please have a try again and let me know if your problem still exists.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Now, the workflows do not immediately fail, but they are 'Running'. Some have been running for hours but no email notifications are sent (email notifications are enabled for all of the approvals), and now nothing is showing up in the Approvals page under the Received or Sent tabs, and there is an error displaying for History. When I checked last night, I had at least 10 approval items received, at least 50 in the sent and a long history of items in the History tab. 27 Jan 2020 - Approvals error 1.PNG27 Jan 2020 - Approvals error 2.PNG27 Jan 2020 - Approvals error 3.PNG

Additionaly several of my flows have failed that I just tested again.

 

Yesterday I was receiving the "Precondition Failed..." error.

27 Jan 2020 - Approval Error.PNG

 

Today I am getting a BadGateway error.

 

27 Jan 2020 - Approvals Flow error - bad gateway.PNG

UPDATE: Issue resolved by recreating the Approvals step in the flows having issues. I followed the advice in a post where a user was having the same issues and the recommeded solution was as follows:

 

"It seems that this seems to be a temporary error, please try to update the connection of the corresponding action or re-create the connection, and then re-submit the Flow."

iivanov1113
New Member

Mary, good day! 
Please tell me, did you manage to defeat this problem?) 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (3,479)