cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
rescoproducts
Level: Powered On

New Form with "Attachments" field Broke. PowerApps SharePoint form won't let me save.

My PowerApps form for SharePoint List broke yesterday.  I ruled it down to the "Attachments" field.  We were only using this to display the attachments (not attach them).  Any "New" item created won't let us save the record when we have the "Attachments" field on our form.  The form works if I remove this field.  Not sure if this is related to any recent changes?  Anyone else experiencing this issue?  It was working before, but now we have to remove this field.

5 REPLIES 5
PowerApps Staff jovan
PowerApps Staff

Re: New Form with "Attachments" field Broke. PowerApps SharePoint form won't let me save.

You are correct, this is indeed a bug.  New items cannot be created if the Attachments control is present on the form.

 

The fix to this bug is ready and will be released by the end of February at the latest.  We are also looking into the possibility of releasing it sooner.

Buck
Level: Powered On

Re: New Form with "Attachments" field Broke. PowerApps SharePoint form won't let me save.

Is this at all related to a new issue I have (not sure exactly when this behavior started):

I have a form used just for viewing info and that has attachments (both it pulls from a SharePoint list.)

Clicking on the attachments no longer results in the attachments opening. It just hangs for a while and then seems to give up. And visually, the selected attachment now has a bold dotted line as a boarder that isn't coded there. 

I can open the attachments directly on SharePoint.

PowerApps Staff jovan
PowerApps Staff

Re: New Form with "Attachments" field Broke. PowerApps SharePoint form won't let me save.

No, this bug is fixed, and shouldn't be related to what you are facing.

 

Do you have an ad blocker in your browser?  We've seen some ad blockers block the download of attachments in some browsers.

Buck
Level: Powered On

Re: New Form with "Attachments" field Broke. PowerApps SharePoint form won't let me save.

Yup, that was it. Thanks!

Odd that it started at some point and wasn't originally a problem.

 

Still not sure about the dotted outline... but that's a minor asthetic thing. I think there was one there before, but now it seems super-bold.

 

PowerApps Staff jovan
PowerApps Staff

Re: New Form with "Attachments" field Broke. PowerApps SharePoint form won't let me save.

I'm not sure whether ad blockers got more stringent, or whether some change we introduced made them start blocking downloads.  Either way, if many users are running into this situation, we will look for ways to improve this behavior.

 

Regarding the dotted outline: you can make the dots smaller by modifying FocusedBorderThickness.