cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
theomr9
New Member

PowerApps not loading

PowerApps always normally work except today, some apps take 20-30 mins to load one App and others won't load at all and get the following message:

Sorry, there's been a disconnect

There was an internal error. Please verify the link and try again.
 
Has been down for 3 hours as of time of posting and looking on PowerApps support there are no known issues.
 
Loading problems across all apps with the same outcome across multiple devices and multiple sites so events are not isolated and appear to be server issues.
2 ACCEPTED SOLUTIONS

Accepted Solutions
robbaldwin
New Member

We can now get in again, however access seems intermittent, some attempts will work, others will not.

View solution in original post

Luke-bpha
Frequent Visitor

Ours also seems back and working (for now).  MS Support has confirmed that there is still an active outage affecting UK and European customers.  Ours seems to be OK at the moment though

View solution in original post

11 REPLIES 11
robbaldwin
New Member

Same here - users aren't able to access PowerApps solutions at the moment. Those already logged in [to the PowerApp] can use as normal, but other users are met with a blank loading screen.

Steve_W
Regular Visitor

Same problem for me - 'Sorry, there's been a disconnect' after waiting several minutes to load. Been like that for a couple of hours. Tried work laptop, home PC, different browsers. Can't run apps or edit apps. The only device that showed any success was the Powerapps app on my android phone - but only to run apps, couldn't access editor.

Luke-bpha
Frequent Visitor

Same problem here (UK based customer).  It's affecting canvas apps embedded in model-driven forms, I've logged a support ticket and patiently waiting for a callback from Microsoft. 

 

A colleague had a support session with Microsoft earlier today to look into a PowerApps issue, wasn't a success as the app would not load.  The support rep informed my colleague there is a service outage that is affecting PowerApps and Power Automate in the UK and European areas.  Still no official communication in O365 service health or their twitter pages though

Thank you for sharing, please update us!

robbaldwin
New Member

We can now get in again, however access seems intermittent, some attempts will work, others will not.

Same here intermittent but better than no access.

And my end is fully resolved and operational, back online

Luke-bpha
Frequent Visitor

Ours also seems back and working (for now).  MS Support has confirmed that there is still an active outage affecting UK and European customers.  Ours seems to be OK at the moment though

Thanks for the update!

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

May UG Leader Call Carousel 768x460.png

June User Group Leader Call

Join us on June 28 for our monthly User Group leader call!

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Users online (1,064)