cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MCraig78
New Member

Error from ASE:token exchange timeout.

Hi guys,

 

I have a workflow that processes email when new mail arrives and redirects based on the subject to a particular SharePoint / document library. Intermittently I appear to be getting the following error on the "When a new email arrives".

 

Status code
520
Headers
{
  "x-ms-failure-cause""apihub-token-exchange",
  "Date""Sun, 08 Oct 2017 17:47:20 GMT",
  "Content-Length""52"
}
Body
{
  "$content-type""application/octet-stream",
  "$content""eyJNZXNzYWdlIjoiRXJyb3IgZnJvbSBBU0U6dG9rZW4gZXhjaGFuZ2UgdGltZW91dC4ifQ=="
}
 
The resulting condition has an error with "Not specified" and I cannot click in to it to see if there is an error (I am assuming it is dying at the "When a new email arrives" step.
 
Has anyone seen this?
 
Thanks!
1 REPLY 1
v-micsh-msft
Community Support
Community Support

Hi @MCraig78,

 

I suspect the error message should be related with the connection credentials.

Please take a try to update the credentials under the connections manage page, see if that would help:

Manage connections in Microsoft Flow

 

 

Error code 520 means the response from the Service can't be recognized, please check of the Email arrived in the Mailbox, see if there are any difference.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,182)