cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
merry
Helper I
Helper I

Issue Importing Canavs app in Dataverse for teams to another team

Hi everyone,

I create an app in dataverse for teams and exported it and then imported it manually to another team . Everything imported and it shows that import is successfully . I see my Canvas app is there in new teams. How ever when I open my Canvas app it is empty. The import through teams in unmanaged so i should be able to the content of Canvas app but nothing is intheer. I even navigated to the App maker and published all Customization in case it is not published. how ever no luck.

 

Can and one help me understand what is the issue please?

It is pretty simple import and export using Dataverse for teams. 

 

Please not i am using free developer license for Office 3656.

 

Thank you so much in advance ,

 

Maryam

 

1 ACCEPTED SOLUTION

Accepted Solutions

I am experiencing strange behaviors if I use out of the box solution for import and export as i mentioned above sometime it is working some times not. How ever it seems that If i use the app maker , I create a new solution and add my items to it and export it as either managed or unmanaged and import it to the target team the power app is happy and import it and it is pretty consistent.

I think there is probably a bug or something out there but with this method it is consistent at least.

 

Thanks,

 

Maryam

View solution in original post

6 REPLIES 6
AhmedSalih
Super User
Super User

Hello, @merry , "imported it manually to another team" Do you mean Imported to another Environment that has Dataverse for Teams?

Are you missing the controls in the Canvas app, or there is no Data showing?

 

Regards,

Ahmed

If my reply helped you, please give a 👍. And if it has solved your issue, please consider a 👍 & Accepting it as the Solution to help other members of the community find it more.

My Blog: www.powerplatformplace.com

Hi Ahmed,

 

I created 2 teams with following names

  1- Event - Dev

  2- Event - Build

 

I built my app in Event- Dev teams . Then I exported it using Export in Dataverse for teams Export button and then I import it it in Event - Build team using the import button. All the Canvas apps, tables and connections are imported and created in the new teams as unmanaged successfully without any errors. However when I open any of my Canvas apps , inside, it is empty. The import and export is unmanaged so it should not be like that. I should be able to see all my the changes that i had done in DEV in Build as well.

I even tries to use the app maker  and export and import the solution from there no luck.

 

Any advise would be much appreciated!

 

Thanks,

 

Maryam

I am missing controls in Canvas app it is basically empty

@merry, can you create a solution and add your app to it then export the solution?

Thanks for suggestion  Ahmed! Sorry for late replay but I tried to test different of way of importing most of them worked for me how ever I do not understand why out of the box import is not working. 

 

 

Here is what i did : I deleted all the Teams and recreated them. I tried 4 different methods

a.Successful: 

- I used the power app maker exported  "Common Data Services Default" Solution  from the dev and imported to another team successfully . (Not sure why it was not working before maybe first time I did not publish all)

- I created a new solution in app maker in DEV Team and exported and imported it to another team and it worked.

- I also exported as Managed from Dev environment and imported Managed in app maker  --> It installed my Canvas App.

 

B. Unsuccessful

- I also used Import and export button using teams and it exported successfully , however I have had tried N number of time to import using Out of the box Import button in Teams. The import did not work. It shows Currently importing customizations from file "Event Registration - DEV 2_export (2).zip" and it hangs forever and when I refresh the page nothing is  imported . I even left it over night. No luck. I am kind of going crazy not sure why. I asked my collage to create a simple app and do the same way of export and import in his personal tenant and  it worked for him we did it together. But in my personal tenant right now it does not give any error and it does not import anything literally. I want to understand our limitation as we might plan to have 1 team per environment and if we do not set up pipeline maybe we use out of the box import feature.  I do not understand why this happening but maybe there is a bug or something as I have 5 teams environment. But the limit is 5

Any idea why this is happening.

 

Please see the 2 attached images  one is showing my teams and the other where the import hangs.

 

My teams ( I only have 5 )

ListOfTeams.PNG

Hanged on the below page

ImportHang.PNG

Aater Import

 

NoSuccessinImport.PNG

 

Thanks,

 

Maryam

 

 

 

I am experiencing strange behaviors if I use out of the box solution for import and export as i mentioned above sometime it is working some times not. How ever it seems that If i use the app maker , I create a new solution and add my items to it and export it as either managed or unmanaged and import it to the target team the power app is happy and import it and it is pretty consistent.

I think there is probably a bug or something out there but with this method it is consistent at least.

 

Thanks,

 

Maryam

Helpful resources

Announcements
October Events

Mark Your Calendars

So many events that are happening this month - don't miss out!

Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Users online (2,633)