cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
annajhaveri
Super User
Super User

Azure Key Vault Connection - Get Secret action

Hello,

 

I want to get value of Secret from Azure Key Vault, but when i add Get Secret action to the Flow, the Flow is not able to connect to Azure Key Vault, i am getting invalid connection error, as shown in below screenshots. The goal of using Azure Key Vault is to get the client secret stored in vault, that client secret will be used in Graph API action in the Flow as we dont want store the client secret directly in the variable and we would want to store it in Azure Key Vault for security reasons.

 

 

  1. Could not retrieve values. Key 'vaultName' not found in connection Profile. When i add the action i see a textbox to enter vault name but then Flow automatically tries to connection with the account and shows this message \Annotation 2020-04-30 215735.png
  2. Flow shows invalid connection error, even though the account connected to the Action has access to Azure Key Vault and account is added under Access Policies in Azure Key VaultAnnotation 2020-04-30 215747.png
  3. When i go to Data -> Connections, the status column of the Azure Key Vault connection, the Status is "Parameter Value Missing"Annotation 2020-04-30 215752.png

Thanks in advance for any help if someone provide to solve this issue, to be able to connect to Azure Key Vault successfully from Power Automate (Flow).

 

Thanks,

Anna Jhaveri 

Regards,
Anna Jhaveri

If I have answered your question, please mark the post as Solved to help other users to identify the correct answer
If you like my response, please give it a Thumbs Up.
4 REPLIES 4
Rahber
Solution Sage
Solution Sage

Hello, This would normally happen when the you have inserted the azure key vault action for the first time and it tries to create a connection with same ID you are creating the flow.

 

In the process it bypasses the step where it needs you to enter the Key Vault Name. So the simple solution is go to connections page. Click edit on the connection for Azure Key Vault. Enter your vault name, fix the sign in issue i.e. authenticate again. Go back to the flow and click on the connection again and your problem will be solved.

 

Thanks,

Rahber

kelway
Helper II
Helper II

Just to add - that the Connections page is under the "Data" menu of Power Automate.

petestanley
New Member

Thanks @Rahber , @kelway your comments really helped!

Syermak
New Member

I went to power automate -> data -> connections -> created a connection to azure key vault -> authenticated it -> status says connected, yet I am still having "Invalid connection" in Get Secret. Anything else I could try?

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

May UG Leader Call Carousel 768x460.png

June User Group Leader Call

Join us on June 28 for our monthly User Group leader call!

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Top Solution Authors
Users online (2,316)