cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BrianS
Super User
Super User

HTTP request failure

I'm trying to retrieve the Exchange email report from the Graph. I'm clearly doing something wrong. I created an app in Azure and generated a "Secret" when I put that in the Flow, it says it is invalid. I have tried both the Secret ID an d the Secret Value, as Flow does not tell you which one it wants. Neither worked. I have consented to both the AnalyticRead permission and the Report.All permission. 

Any idea what value I have wrong? Is there a better way to do this? My manager wants this report (heavily edited) every week.

6 REPLIES 6
abm
Super User
Super User

Hi @BrianS 

 

Are you using the Graph API?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
BrianS
Super User
Super User

I thought so - I'm using the HTTP with the Green Globe icon with a GET to graph.microsoft.com etc

 

Hi @BrianS 

 

Could you post a screenshot of your flow?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
BrianS
Super User
Super User

Here you goGraph_01.png

Hi @BrianS 

 

Thanks for your reply. I can see you are using the GRAPH API.

 

There is new connector in flow which can directly access the GRAPH API. You don't need any secret key and azure portal registrations. 

 

image.png

 

All you need to do is select the Office 365 Groups connector and action step called Send an HTTP request. The connection is similar like any other connector. Just the username and password. 

 

Try the API via this connector and see if that works or not. Please let me know.



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
BrianS
Super User
Super User

This did not work either, but I received a different error

"URI path is not a valid Graph endpoint"

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

New Process Advisor Capabilities carousel.png

Read the blog for the latest news

Read the latest about new experiences and capabilities in the Power Automate product blog.

PA Survey Carousel Image.png

We want to hear from you!

If you are a small business ISV/Reseller, share your thoughts with our research team.

Top Solution Authors
Users online (3,019)