cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

Flow (excel connector) not detecting SharePoint subsites

I am creating a Flow to detect changes in an Excel file which will then trigger subsequent steps. 

The problem I've ran into however, is that when I try and select the 'location'... only the top level sites are shown, not subsites. 

 

The difference is that the sharepoint connector has no problem finding subsites... 

 

Is this expected? Am I able to connect to excel files within subsites?

 

Regards,

CameronTCD

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Dual Super User III
Dual Super User III

Re: Flow (excel connector) not detecting SharePoint subsites

Hey @CameronTCD 

 

I tried some other combinations too but this definitely looks like a bug. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

5 REPLIES 5
Highlighted
Dual Super User III
Dual Super User III

Re: Flow (excel connector) not detecting SharePoint subsites

Hey @CameronTCD 

 

I am able to see the subsites in the excel connector too: nh.PNG

The highlighted ones at the bottom are the subsites that I have created. You can scrolll down and check to find those subsites in the action too. 

 

If not, you can enter the url of the site as https://yourorgname.sharepoint.com/sites/parentsite/subsite and access the same. 

 

You might want to try saving the flow and log out of the browser session, start a fresh session and check this. (it might be due to a caching issue or the subsites were created after adding the action in flow)

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Helper II
Helper II

Re: Flow (excel connector) not detecting SharePoint subsites

Hi @yashag2255 

 

This subsite was created weeks ago, the flow was only created this morning.

Despite this, the subsite can't seem to be located on the subsequent dropdown (see below)

 

 

 

I would use the URL however I then get this error!

Highlighted
Dual Super User III
Dual Super User III

Re: Flow (excel connector) not detecting SharePoint subsites

Hey @CameronTCD 

 

I just checked in my environment and it kind of does not work when there are spaces in the name (eventually the url) of the site or subsite. In such cases it is working only when the site is selected from the dropdown. Can you do a Ctrl + F5 and add the excel action again to check if you are able to see the subsite now? 

 

You can report it as a bug here: https://powerusers.microsoft.com/t5/I-Found-A-Bug/bd-p/BugFound and/ or raise a ticket for this issue here: https://admin.powerplatform.microsoft.com/support?newTicket&product=Flow

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Helper II
Helper II

Re: Flow (excel connector) not detecting SharePoint subsites

Hey @yashag2255 

 

Unfortunately, that's also not worked.

 

I feel that this may just be a bug?

 

Regards,

CameronTCD

Highlighted
Dual Super User III
Dual Super User III

Re: Flow (excel connector) not detecting SharePoint subsites

Hey @CameronTCD 

 

I tried some other combinations too but this definitely looks like a bug. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (5,915)