cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KHammer
Helper I
Helper I

Unknown Error when Adding to Table

Hello,

 

I have been working on this flow for some time and it seems like most problems have worked out except that now I keep getting an error when trying to add data to my automatically created worksheet table.

 

All it says is "Bad Request" and I have no idea what to change or what I can do to fix this..

Bad RequestBad RequestI have tried deleting the connector multiple times, I am unsure if it has to do with my table name? Which I tried to make dynamic by making it something simple like test_(Variable('worksheet_ID')).

 

But I have had this same issue when just making it simple like Dog as a custom table.

Even though I have Create a Worksheet and Create a Table connectors before this part in the Flow it does not register under the Add to Table (Table Name) row...

 

If anyone has any ideas please let me know.

2 ACCEPTED SOLUTIONS

Accepted Solutions
abm
Super User
Super User

Hi @KHammer 

 

Please have a look at my video which explains regarding add rows using JSON formatted values.

 

 

https://youtu.be/pKKk-sgyDYE

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

View solution in original post

Hi @KHammer 

 

Good to hear about the progress. Need to see the flow to find out the first point regarding JSON file was sent as an Apply to each the same data was sent over multiple times. The date one you need to convert to date format. Have a look on community and also in my channel there is a video about Excel Date.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

View solution in original post

11 REPLIES 11
abm
Super User
Super User

Hi @KHammer 

 

Its not the connector issue. Could you post  a screenshot of your mappings? Ideally an English version.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
KHammer
Helper I
Helper I

Hello @abm 

Sorry I am probably misunderstanding, is mappings the same as the rest of the flow?

For what I can`t translate I will try to anotate.

abm
Super User
Super User

Hi @KHammer 

 

Check all the column values are mapped. Believe you are passing as single JSON format? Check the order of column names similar to Excel.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Hello @abm ,

 

I will post a screenshot below.

I am making a worksheet and table automatically and so because of this it was not registering the table name that I have entered in the past. So for the Add Rows portion where it asks for the Table name I used the dynamic Table name option and it only came with one option for Rows, thus I put value down...

 

I tried to annotate the flow for my thought process

 

FlowFlowApply to EachApply to Each

If the Create a Table portion didn`t automatically turn into an Apply to Each... I assume then that the options for each row would show up in the Add Row function... but if it turned into an Apply to Each I feel like it would screw up even more.

Hi @KHammer 

 

I managed to replicate  your error. I will explain this in a video soon.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
abm
Super User
Super User

Hi @KHammer 

 

Please have a look at my video which explains regarding add rows using JSON formatted values.

 

 

https://youtu.be/pKKk-sgyDYE

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
KHammer
Helper I
Helper I

Hello @abm 

 

Thnk you for the video, it was very easy to understand!

I was able to get the data sent to the new worksheet`s table however as a result two unexpected things occured.

 

1) I think because the JSON file was sent as an Apply to each the same data was sent over multiple times, thus I am getting triple the data and I am wondering how to only keep the data I need.

 

2) My time and dates are an already converted value in the original table and even though I am pulling data from this table it gets reconverted back into what I believe is Decimal UTC time. I have tried to reconvert this but it once again creates an Apply to Each loop and the output is not selectable in my JSON composition.

 

Multiplied resultsMultiplied resultsOriginal Date DataOriginal Date Data

Changed Date DataChanged Date Data

Thank you for the help so far as this is real progress!

 

Hi @KHammer 

 

Good to hear about the progress. Need to see the flow to find out the first point regarding JSON file was sent as an Apply to each the same data was sent over multiple times. The date one you need to convert to date format. Have a look on community and also in my channel there is a video about Excel Date.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Hello @abm 

 

With some fiddling I was able to rearrange to make it so only the filtered items (I believe) were then converted into JSON to then be added to the table.

 

I have been getting this error where if I use the dynamic date from the original table it turns everything into an Apply to Each loop... I have been able to avoid that somehow with my current Flow but now I am at the last stage I believe where for some reason it is not accepting my converted time value as the new updated value...

 

Updated Flow using Current Item in JSONUpdated Flow using Current Item in JSONErrorError

KHammer
Helper I
Helper I

Hello @abm 

 

I got it to work! I used the converted value and did another JSON conversion to use in the add row to table connector.

 

Thank you so much.

 

I had a smaller question but did you happen to know if there is a way to program excel column width for dynamic tables?

Hi @KHammer 

 

Fantastic finally you got it. All good news and thanks for letting me know. Regarding the column width please have a look on Excel Run Script action step. That might do the job.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Users online (1,528)