cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ovo
Helper I
Helper I

Bad Gateway : Error 502

My flow used to work perfectly : When a new file is dropped in one particular folder in onedrive, i get an email.

 

Since July 11th, my flow give me a Bad Gateway" message :

 

{
"error": {
"code": 502,
"source": "flow-apim-msmanaged-na-eastus2-01.azure-apim.net",
"clientRequestId": "b1d0b56d-a837-4974-8f5d-c8b6ccda4ecc",
"message": "BadGateway",
"innerError": {
"status": 502,
"message": "Unable to connect to the remote server.\r\n inner exception: An error occurred while sending the request.\r\n inner exception: Unable to connect to the remote server\r\n inner exception: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 40.108.138.90:443",
"source": "api.connectorp.svc.ms"
}
}
 
Any idea how to fix it?
 
Thank you !
 
 
5 REPLIES 5
ovo
Helper I
Helper I

Capture2.JPG

v-bacao-msft
Community Support
Community Support

Hi @ovo ,

 

I have tested it on my side and hasn't met the same issue.

Did the issue happen on some files or all files when you dropped files?

You could try the following methods:

  • Recreate the connection of OneDrive connector, or you could recreate a similar Flow to test.
  • Clear your browser cache and delete cookies then do a similar test.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
heyrohit
New Member

I have the same issue and I have tried deleting all one drive connections. Created a new one. Still I have the same issue.

 

 

I am having the same issue, this issue is profoundly annoying, it works well today tomorrow it wont, as of now saving the flow fixes the issue temporarily but its not a long term solution, please please have a fix for this. 

I had this issue last week, then sporadic failures. If you look at the specific error message it gives you a hint as to what exactly the cause is. Support has not been useful as they will just go over the whole rebuild reconnect song and dance.

 

In my specific error it stated office svc failure:

Power Automate - Bad Gateway 502 -1.18.20.JPG

The body message gives detail of what exactly is failing as not all 502 gateways are created equal.

My issue was eventually sent over to the sharepoint group. Who knows if it belongs there as the issue has gone away on its own again.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,715)