cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WillPage
Impactful Individual
Impactful Individual

Republishing a bot

I've built a simple bot in PVA, and added it to Teams. When I update the topics in PVA and republish, the responses in Teams don't reflect the changes. The App ID stays the same so removing the bot from the Teams app and re-adding it has no effect. It doesn't look like the bot's topics and responses have changed since the first ever publish.

 

I can't find any documentation about this. I hope I don't have to delete the App ID every time I update the bot then update the Teams App manually.

4 REPLIES 4
renatoromao
Super User
Super User

We don't have yet the documentation explaining how can you clean cache, but you can try to run CTRL + F5 sometimes in the browser and you can wait until 24 hours (normally Microsoft use this time clean completely cache of the tools). And you can close the Microsoft Teams and open again.

 

I created the idea: https://powerusers.microsoft.com/t5/Power-Apps-Ideas/Clear-or-determine-clear-cache-Power-Virtual-Ag...

 

When I see something like that, I send it here. 🙂 


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.300 students | PROMOTIONS) : English | Português
WillPage
Impactful Individual
Impactful Individual

Thanks.

 

I still cannot access topics I created last week when in a Teams channel, but in the private chat it's perfect. The odd thing is, in the Teams channel, it doesn't even understand the greeting

image.png

 

..but it can understand when I want a Chuck Norris joke (the power of Chuck perhaps?):

image.png

 

I think there's more to it than just a timeout on old conversations. I've removed and re-added the bot to the team a few times, restarted Teams and even completely removed the bot from the whole org using my admin account and re-added it. Even some new topics I add show up, but older ones never do. The greeting is built in and it doesn't pick that up properly.

Facing the same issue in Teams, Not sure why new topics are not publishing instantly. 

Thank you for using Power Virtual Agents.  Our documentation has been updated to clarify how publishing bot content works with existing Teams conversations:

https://docs.microsoft.com/en-us/power-virtual-agents/publication-add-bot-to-microsoft-teams

 

Currently PVA bots only support 'Personal' scope so chatting with the bot in channels/group chat is not supported.  This ability is on our road map in future release.  Thank you.

Helpful resources

Announcements
March Update

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Virtual Agents innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

New Super Users

Meet the Power Virtual Agents Community Super Users!

Congratulations to our Season 1 2021 Super User Crew!

Top Solution Authors
Users online (73,130)