cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Adaptive Card errors in MS Teams "We're sorry, this card couldn't be displayed".

I have a very simple Adaptive card posting to Teams on Planner Task completion.  It was working before I went on holiday and then the owner asked for a very simple change.

 

I made the change (re-created the card in the adaptive card designer but really only removed one line of text) and now when I test the flow it doesn't work.

 

Flow says it has succeeded and the Output in there looks ok but in the Teams channel I get this:

 

suclarkeuk_0-1597132515276.png

 

There isn't really much for me to go on for troubleshooting here.  Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Advocate I
Advocate I

Ok I solved it but gonna leave this here in case it helps anyone else out.

 

Some point in the last 2 weeks the version of the Adaptive card designer I've been using (https://adaptivecards.io/designer/) changed from ver 1.2 to 1.3.  That seems to have caused the problem.  

 

When I amended the JSON to be ver 1.2 and re-tested the card can through fine.

View solution in original post

5 REPLIES 5
Advocate I
Advocate I

Ok I solved it but gonna leave this here in case it helps anyone else out.

 

Some point in the last 2 weeks the version of the Adaptive card designer I've been using (https://adaptivecards.io/designer/) changed from ver 1.2 to 1.3.  That seems to have caused the problem.  

 

When I amended the JSON to be ver 1.2 and re-tested the card can through fine.

View solution in original post

Frequent Visitor

I'm having the same problem, v1.3 doesn't work at all. 

I specifically need the data validation function in v1.3, what is the real fix? 

I'm just trying a single date field, very simple. 

{​​​​​
    "type""AdaptiveCard",
    "version""1.3",
    "body": [
        {​​​​​
            "type""Input.Date",
            "id""startDate",
            "value""2020-01-01",
            "min""2000-01-01",
            "max""2099-01-01",
            "errorMessage""Start date is invalid"
        }​​​​​
    ]
}​​​​​
 
Teams displays this 
 

PowerError.png

Its saying something like Teams might not support 1.3 in the designer? 

PowerError2.png

 

 

Hi, did you resolve the issue? I'm receiving the same issue and also I have v1.3. I'm not sure where the issue could be.

Thank you,

Jan

Regular Visitor

I'm also having this issue when using v1.3

No, we gave up, decided to try adaptive cards next year or maybe never? 

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (6,491)